Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-36305

Reply button in forums not shown in MyMobile theme

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.6, 2.3.3, 2.4
    • Fix Version/s: 2.2.7, 2.3.4
    • Component/s: Themes
    • Labels:
    • Testing Instructions:

      Test pre-requisites

      • A forum with a topic and several posts
      • Use the mymobile theme

      Test steps

      1. Visit the topic
      2. Make sure you don't see the 'Show parent' link (2.2 and 2.3 only)
      3. Make sure clicking on 'Reply' works
      Show
      Test pre-requisites A forum with a topic and several posts Use the mymobile theme Test steps Visit the topic Make sure you don't see the 'Show parent' link (2.2 and 2.3 only) Make sure clicking on 'Reply' works
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-36305-master

      Description

      Reply buttons at forums are not shown using MyMobile theme.

      Problem seems to be related with changes made at MDL-30909.

      Javascript's theme removes a tags of class ".options div.commands a" that have an anchor in its href... and that includes Reply button.

      It affects 2.3.2+

        Gliffy Diagrams

          Issue Links

            Activity

            salvetore Michael de Raadt added a comment -

            Thanks for reporting that and finding the cause.

            Feel free to help us resolve the issue.

            jsegarra Juan Segarra Montesinos added a comment -

            Hi again,

            It's the jquery mobile problem reported here:

            https://github.com/jquery/jquery-mobile/issues/4119

            I've patched the library and worked for me.

            jsegarra Juan Segarra Montesinos added a comment -

            I've updated mymobile's jquery mobile version to 1.1.1 (not a big jump and solves the issue). Also, i've shown again the "Parent Post" button.

            Please take a look at:

            https://github.com/juancs/moodle/commit/1dfe58954af6f6916463a8fa28d3ba07b54be205

            Thank you.

            fred Frédéric Massart added a comment -

            Thanks for providing the patch Juan. I have kept it intact for master, but I have created different branches for 2.2 and 2.3.

            So apparently jQuery Mobile prior to 1.1.1 did not handle the anchors in links. What I have done for 2.2 and 2.3 is to remove all the links containing an anchor as it was previously done, except for the reply one. For the reply one, I simple removed the anchor from the link.

            Thanks!

            markn Mark Nelson added a comment -

            2.2 and 2.3 look ok, but master introduces a lot of whitespaces.

            fred Frédéric Massart added a comment -

            Thanks Mark, that's because it is part of an external library, so we don't care about them. Cheers!

            nebgor Aparup Banerjee added a comment -

            Thanks guys, this has been integrated into 22, 23 and master.

            salvetore Michael de Raadt added a comment -

            I will test this and the MyMobile QA test.

            salvetore Michael de Raadt added a comment -

            Test result: Success!

            I was able to post replies in forums in master, 2.3 and 2.2.

            There was an issue related to displaying activity links in master. I will raise that separately.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Y E S !

            Closing as fixed, many thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/Jan/13