Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.2.5
    • Fix Version/s: None
    • Component/s: JavaScript, SCORM
    • Labels:
    • Affected Branches:
      MOODLE_22_STABLE

      Description

      There are two warnings in the JS console when playing a SCORM package.

      Use of getAttributeNode() is deprecated. Use getAttribute() instead.

      oAttribute = p_oElement.getAttributeNode(p_sAttribute);

      AND

      The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it.

        Gliffy Diagrams

          Issue Links

            Activity

            dobedobedoh Andrew Nicols added a comment -

            Mark,

            Can you provide a little more detail - a backtrace would be great. Is this only on a specific SCORM package?

            I only see getAttributeNode used a handful of times in core, most all of which are in external libraries (tinyMCE, YUI 2.9.0, xhprof's jquery).

            markn Mark Nelson added a comment -

            Hi Andrew, I sent you the SCORM package I was using. Just fyi, these errors were displayed in firebug's JS console (not sure if all JS debugging tools are as strict as each other).

            dobedobedoh Andrew Nicols added a comment -

            I think these warnings stem from use of YUI 2.9 button elements in the SCORM Navigation. At present it's all YUI2.

            I'm going to mark this as a Won't Fix because it's just a warning, and is caused by a third-party lib, but I've raised MDL-36374 to address the rewriting of the SCORM JS in YUI3.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: