Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.4, 2.5
    • Fix Version/s: 2.4.1
    • Component/s: Calendar
    • Labels:
    • Testing Instructions:
      1. Log in as an admin
      2. Make sure there is a calendar block on the frontpage.
      3. Browse to the calendar and add an event to the tomorrow.
      4. Browse back to the front page.
      5. Mouse over tomorrow in the calendar box.
      6. Make sure you see a popup.
      Show
      Log in as an admin Make sure there is a calendar block on the frontpage. Browse to the calendar and add an event to the tomorrow. Browse back to the front page. Mouse over tomorrow in the calendar box. Make sure you see a popup.
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull Master Branch:
      wip-MDL-36341-m24

      Description

      This is a regression caused by MDL-16660, commit 4c349ad7.

      1. Create some calendar events
      2. Go to a page where the calendar block is displayed
      3. Mouse over some events

      Expected

      • A popup is displayed with events info

      Actual

      • Nothing happens

      Reverting this should work:

      // calendar/yui/eventmanager/eventmanager.js
      -                    var n = Y.one(node);
      -                    if (!n) {
      -                        Y.fail(ENAME+': invalid event node set');
      -                    }
      +                    var n = Y.one('#'+node);

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              Sam: I've assigned this to you as you were involved in integrating the original patch.

              ankit_frenz Ankit Agarwal added a comment -

              making this as a sub-task of the ical meta.
              Thanks

              samhemelryk Sam Hemelryk added a comment -

              Putting this up for integration now.

              I couldn't reproduce it in any of the stable branches, only master so this is a master only patch.

              Many thanks
              Sam

              fred Frédéric Massart added a comment -

              Hi Sam,

              I like the way you handle both possibilities (string and node). Only, I think there could be a problem when the node is a node and not a string. The returned variable n would be undefined. I guess we want to set n to node before that.

              Cheers!
              Fred

              samhemelryk Sam Hemelryk added a comment -

              Thanks Fred, you're dead right, should a YUI node be passed there will be an exception.
              I've fixed that up now and pushed this up for integration.

              Many thanks
              Sam

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated (24 and master), thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              And passed (while integrating), congrats!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              This has landed upstream, closing, thanks!


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    14/Jan/13