Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-36368

regression in Sky High theme page-header caused by RTL fix in Base theme

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      1. Select Sky High theme and note header and footer images are clouds/birds predominantly to the right.
      2. Change to RTL lang mode for example: Hebrew (he)
      3. Test that header background image covers the whole of the header and not squashed to the right as it was in regression.
      4. Test both header & footer background images are the mirror images (clouds/birds predominately to the left) as those of the original Sky High header/footer in normal view.
      Show
      Select Sky High theme and note header and footer images are clouds/birds predominantly to the right. Change to RTL lang mode for example: Hebrew (he) Test that header background image covers the whole of the header and not squashed to the right as it was in regression. Test both header & footer background images are the mirror images (clouds/birds predominately to the left) as those of the original Sky High header/footer in normal view.
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull Master Branch:
      MDL-36368_master

      Description

      Found when testing another RTL related issue. Sky High page-header looses background image when floating right when in RTL mode. This is a regression caused by recent RTL fix in MDL-35275. Fortunately it's easy to fix.

        Gliffy Diagrams

          Attachments

            Activity

            poltawski Dan Poltawski added a comment -

            Thanks Mary, i've integrated this now

            abgreeve Adrian Greeve added a comment -

            Tested on integration and normal branches.
            The page header isn't all bunched up as before (It now looks normal).
            Test passed.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Amazed. Inspired. Grateful. That’s how your generosity makes me feel.

            (not really)

            Closing, thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  3/Dec/12