Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-36413

Incorrect local variable instead of class variable assignment in user/selector/lib.php

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.8, 2.2.5, 2.3.2, 2.4
    • Fix Version/s: 2.2.7, 2.3.4
    • Component/s: General
    • Labels:

      Description

      In the method clear_exclusions() of the abstract class user_selector_base, the variable $exclude is set to array(). It should be $this->exclude = array().

        Gliffy Diagrams

          Attachments

            Activity

            skodak Petr Skoda added a comment -

            +1, thanks!

            skodak Petr Skoda added a comment -

            Hello Nicolas, could you please add some testing instructions if applicable. Thanks a lot for the report and patch.

            poltawski Dan Poltawski added a comment -

            Looks like this isn't used anywhere in core, so can't be tested easily.

            poltawski Dan Poltawski added a comment -

            Thanks Nicolas, i've integrated this now!

            poltawski Dan Poltawski added a comment -

            I did a very very quick regression test, as mentioned this can't easily be tested.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Many, many thanks for your effort!

            Millions of people will enjoy the results of your work, yay!

            Closing as fixed. Ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/Jan/13