Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-36696

filepicker.js has superfluous comma which prevents the filepicker loading in IE

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.3.3
    • Fix Version/s: 2.3.4
    • Component/s: Filepicker
    • Labels:
    • Testing Instructions:

      In Moodle 2.3:

      1. Force IE into compatibility mode (IE7 mode worse case, but I found IE8 mode also caused problems)
      2. Load a page with the filepicker
      3. No errors should be seen and the filepicker should load)

      In Moodle 2.4 it shouldn't be possible for IE to go into compatibility mode and this change was actually done elsewhere, so shouldn't need testing.

      Show
      In Moodle 2.3: Force IE into compatibility mode (IE7 mode worse case, but I found IE8 mode also caused problems) Load a page with the filepicker No errors should be seen and the filepicker should load) In Moodle 2.4 it shouldn't be possible for IE to go into compatibility mode and this change was actually done elsewhere, so shouldn't need testing.
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
      MDL-36696-master

      Description

      The file picker will not load in Internet Explorer (tested in IE 8 and 9) due to a superfluous comma on line 1027 in filepicker.js

      1027: repo_id: this.active_repo.id,

      Need to be,

      1027: repo_id: this.active_repo.id

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              poltawski Dan Poltawski added a comment - - edited

              As commented in private chat, I believe this is related to to IE8/9 going into 'compatibility mode' i.e. like IE7.

              Paul confirmed this was the case. But this is still serious anyway as lots of sites will be mistakenly going into compatibility mode in 2.3. But we should still solve it for IE7 users and 'compatibility mode' people anyway.

              poltawski Dan Poltawski added a comment - - edited

              Introduced by 82525f5963b2a288dfa9c01201e62dea8bfbc788 (MDL-35664)

              poltawski Dan Poltawski added a comment -

              Assiging this to moodle.com whilst I can't assign it to Paul.

              poltawski Dan Poltawski added a comment -

              Taking this straight into integration, since its simple to fix

              poltawski Dan Poltawski added a comment -

              This was fixed in master by e13b330d already.

              poltawski Dan Poltawski added a comment -

              Thanks Paul, i've integrated this now

              abgreeve Adrian Greeve added a comment -

              Tested on the 2.3 stable and integration branches. (I had a quick look at master as well)
              I first reproduced the problem and then observed the fix.
              All works as described.
              Test passed.

              poltawski Dan Poltawski added a comment -

              Congratulations! Another bug solved.. only another 7330 to go, thanks for contributing to contributing to 0.8% of all bugs being fixed this week!

              ciao
              Dan


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    14/Jan/13