Moodle
  1. Moodle
  2. MDL-36742

Question bank popup blinks on screen when quesiton bank loads

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.2.7, 2.3.4
    • Component/s: Questions
    • Labels:
    • Testing Instructions:
      Hide

      1. You need to check the 'Edit quiz' and 'Question bank' page for a quiz.

      2. During the page load, check that the there is not a nasty flicker as the "Choose a question type to add" dialogue appears and then disappears.

      3. Check that the dialogue does appear, and works, when you click the "Create a new question" or "Add a question ..." (quiz edit page only) buttons.

      Show
      1. You need to check the 'Edit quiz' and 'Question bank' page for a quiz. 2. During the page load, check that the there is not a nasty flicker as the "Choose a question type to add" dialogue appears and then disappears. 3. Check that the dialogue does appear, and works, when you click the "Create a new question" or "Add a question ..." (quiz edit page only) buttons.
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull from Repository:
    • Rank:
      46248

      Description

      I was completing these two steps from MDLQA-4838

      1. Login as a teacher and go to the question bank in a course.
      2. Click the 'Create a new question' box and select numerical.

      And each time I loaded the question bank, I saw the quesiton bank popup initially

        Activity

        Hide
        Dan Poltawski added a comment -

        (in chrome)

        Show
        Dan Poltawski added a comment - (in chrome)
        Hide
        Frédéric Massart added a comment -

        Fixed in an issue of MDL-34080. I don't remember which one, but the problem was basically that the popup was set to visible when the class .jsenabled was set in <body>. I removed it to be hidden all the time as JS will unhide it. It might be worth using this issue to backport it though.

        Show
        Frédéric Massart added a comment - Fixed in an issue of MDL-34080 . I don't remember which one, but the problem was basically that the popup was set to visible when the class .jsenabled was set in <body>. I removed it to be hidden all the time as JS will unhide it. It might be worth using this issue to backport it though.
        Hide
        Tim Hunt added a comment -

        Well, if you can provide a more specific pointer to the relevant code change, then I am happy to back-port it.

        Show
        Tim Hunt added a comment - Well, if you can provide a more specific pointer to the relevant code change, then I am happy to back-port it.
        Hide
        Tim Hunt added a comment -

        This bugs me too, so I will backport the fix, if someone can point me in the right direction.

        Show
        Tim Hunt added a comment - This bugs me too, so I will backport the fix, if someone can point me in the right direction.
        Hide
        Dan Poltawski added a comment -

        Just seen it while reviewing MDL-36623:

        diff --git a/theme/base/style/question.css b/theme/base/style/question.css
        index 3d4a13c..b5156d7 100644
        — a/theme/base/style/question.css
        +++ b/theme/base/style/question.css
        @@ -13,7 +13,6 @@
        #chooseqtype .submitbuttons

        {margin: 0.7em 0;text-align: center;}

        #qtypechoicecontainer

        {display: none;}

        -body.jsenabled #qtypechoicecontainer

        {display: block;}
        Show
        Dan Poltawski added a comment - Just seen it while reviewing MDL-36623 : diff --git a/theme/base/style/question.css b/theme/base/style/question.css index 3d4a13c..b5156d7 100644 — a/theme/base/style/question.css +++ b/theme/base/style/question.css @@ -13,7 +13,6 @@ #chooseqtype .submitbuttons {margin: 0.7em 0;text-align: center;} #qtypechoicecontainer {display: none;} -body.jsenabled #qtypechoicecontainer {display: block;}
        Hide
        Tim Hunt added a comment -

        Thanks Fred. I am sure that display: block rule used to be necessary once upon a time, but clearly not any more.

        Show
        Tim Hunt added a comment - Thanks Fred. I am sure that display: block rule used to be necessary once upon a time, but clearly not any more.
        Hide
        Dan Poltawski added a comment -

        Thanks Tim, i've integrated this now.

        Show
        Dan Poltawski added a comment - Thanks Tim, i've integrated this now.
        Hide
        Andrew Davis added a comment -

        Works as described. Passing.

        Show
        Andrew Davis added a comment - Works as described. Passing.
        Hide
        Eloy Lafuente (stronk7) added a comment -

        Many thanks for your effort, the whole Moodle Community will be enjoying your great solutions starting now!

        Closing, ciao

        Show
        Eloy Lafuente (stronk7) added a comment - Many thanks for your effort, the whole Moodle Community will be enjoying your great solutions starting now! Closing, ciao

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: