Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-36754

Images are not displayed in forum messages received by email for courses requiring authentication

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Enable mailcatcher, mailhog, or have e-mail configured
      2. Setup a user with a profile picture
      3. Create a course, enrol some users
      4. Create a forum in the course
      5. Create 2 groups and put your test user in both groups
      6. Put pictures on both groups
      7. Reduce the maxeditingtime to something really low
      8. Post in the forum as the user:
        1. Include several images as attachments using the "Insert or edit image" button ("images A") - Don't use the URL feature but the file manager to pick up the images (this already works in principle).
        2. Include several images as attachments using the file attachment manager underneath the text editor ("images B")
      9. Run cron:

        php admin/tool/task/cli/schedule_task.php --execute="\mod_forum\task\cron_task" 
        

      10. Ensure that you're fully logged out of Moodle everywhere
      11. Open mailhog/mailcatcher/etc and find the e-mail
        1. Confirm that the group photos, user pictures, and "images A" are shown
        2. Confirm that there is a link for "images B"
        3. Confirm that following the link for the other attachment takes you to the login page
      Show
      Enable mailcatcher, mailhog, or have e-mail configured Setup a user with a profile picture Create a course, enrol some users Create a forum in the course Create 2 groups and put your test user in both groups Put pictures on both groups Reduce the maxeditingtime to something really low Post in the forum as the user: Include several images as attachments using the " Insert or edit image " button (" images A ") - Don't use the URL feature but the file manager to pick up the images (this already works in principle). Include several images as attachments using the file attachment manager underneath the text editor (" images B ") Run cron: php admin/tool/task/cli/schedule_task.php --execute="\mod_forum\task\cron_task" Ensure that you're fully logged out of Moodle everywhere Open mailhog/mailcatcher/etc and find the e-mail Confirm that the group photos, user pictures, and "images A" are shown Confirm that there is a link for "images B" Confirm that following the link for the other attachment takes you to the login page
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE, MOODLE_25_STABLE, MOODLE_26_STABLE, MOODLE_28_STABLE, MOODLE_31_STABLE, MOODLE_33_STABLE
    • Fixed Branches:
      MOODLE_36_STABLE
    • Pull Master Branch:
      MDL-36754-master

      Description

      I am considering here the received emails originating from a forum of a course requiring authentication.

      A. There are two problems with group images in emails:

      1. Group images are NOT displayed at all in received emails when the course require authentication.

      2. Group images are display horizontally and not vertically in a email (which can create a space problem when the user is a member of several groups). Note that the group images are shown vertically in the forum of a Moodle site.

      B. Images uploaded in a message are not displayed when the course require authentication (images will display only when the image URL is provided).

      Tested with the Clean and Essential themes.

      See also http://tracker.moodle.org/browse/MDLSITE-1083

        Attachments

        1. Capture-email-received.PNG
          Capture-email-received.PNG
          16 kB
        2. Capture-message-posted.PNG
          Capture-message-posted.PNG
          186 kB
        3. mailview.png
          mailview.png
          571 kB
        4. screenshot-1.png
          screenshot-1.png
          98 kB
        5. webview.png
          webview.png
          1.04 MB

          Issue Links

            Activity

              People

              • Votes:
                12 Vote for this issue
                Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  3/Dec/18

                  Time Tracking

                  Estimated:
                  Original Estimate - 0 minutes
                  0m
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 40 minutes
                  40m