Moodle
  1. Moodle
  2. MDL-36826

Only one feedback file is shown for one group member in an assignment.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      1. Create an assignment with 'Feedback files' set to yes, and 'Students submit in groups' set to Yes.
      2. Create a group called 'Group 1' and put two students in 'Group 1'.
      3. As the teacher, open the grading page for the first student from the group (From View/grade all submissions)
      4. Provide a grade, attach a feedback file, ensure 'Apply grades and feedback to entire group' is set to yes and then click 'Save changes'.
      5. Verify that the feedback file was sent to both members of Group 1.
      Show
      Create an assignment with 'Feedback files' set to yes, and 'Students submit in groups' set to Yes. Create a group called 'Group 1' and put two students in 'Group 1'. As the teacher, open the grading page for the first student from the group (From View/grade all submissions) Provide a grade, attach a feedback file, ensure 'Apply grades and feedback to entire group' is set to yes and then click 'Save changes'. Verify that the feedback file was sent to both members of Group 1.
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-36826-master

      Description

      1. Create an assignment with 'Feedback comments' set to yes, 'Feedback files' set to yes, and 'Students submit in groups' set to groups.
      2. Create a group called 'Group 1' and put two students in 'Group 1'.
      3. Submit the assignment for just one student.
      4. As the teacher, click the Assignment -> View/grade all submissions -> Grade.
      5. Provide a grade, feedback and attach a file to your feedback - ensure 'Apply grades and feedback to entire group' is set to yes then 'Save changes'.
      6. On the next page notice how the file is not listed next to each student in that group - only the feedback and grade is.

        Gliffy Diagrams

          Issue Links

            Activity

            Damyon Wiese added a comment -

            Thanks Mark - I'll take a look.

            Damyon Wiese added a comment -

            This was caused by the changes to make the name of the filemanager unique for each student. In this particular case we are re-using the form submission for one student and applying it to all members of the group. This means that the file feedback plugin can't assume that the name of the file manager element should match the id of the current student and must find it in the submission data instead.

            This is a good reason to move to storing the ordered list of userids in MUC (later) instead of in the form which would remove this complexity from the assignment plugins (but can't be backported). I'll add a new issue for this.

            Sam Hemelryk added a comment -

            Thanks Damyon
            This has been integrated now.

            Sam Hemelryk added a comment -

            Testing will be covered by MDLQA-5213

            Eloy Lafuente (stronk7) added a comment -

            Y E S !

            Closing as fixed, many thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: