Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-36835

Turning quick grading on or off in Chrome/Safari warns the user about leaving the page with unsaved changes

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.3, 2.4
    • Fix Version/s: 2.3.4, 2.4.1
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      1. Using Chrome, Go to the grading page for an assignment that is not using advanced grading
      2. Click the checkbox at the bottom of the page: "Quick grading"
      3. Verify you do not receive a javascript warning.
      4. With quick grading enabled, enter a new grade for one of the submissions
      5. Click the checkbox at the bottom of the page: "Quick grading"
      6. Verify you do receive a javascript warning about unsaved changes.
      Show
      Using Chrome, Go to the grading page for an assignment that is not using advanced grading Click the checkbox at the bottom of the page: "Quick grading" Verify you do not receive a javascript warning. With quick grading enabled, enter a new grade for one of the submissions Click the checkbox at the bottom of the page: "Quick grading" Verify you do receive a javascript warning about unsaved changes.
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-36835-master

      Description

      I tried to replicate this in FF, IE and Opera, but only Chrome and Safari (Webkit browsers) behaved this way.

      The warning appears having made no changes on the page.

      Test prerequisites:

      • A course with users enrolled
      • An assignment (with or without submissions)

      Replication steps:

      1. Log in as a teacher
      2. Navigate to the course
      3. Navigate to the assignment
      4. View submissions
      5. Click the checkbox for Quick grading

      Expected result: The page should refresh allowing for quick grading

      Actual result: In Chrome and Safari, the browser warns the user about leaving the page with "You have made changes". This happens when you turn quick grading off also.

      Perhaps there is some JS that is changing a hidden form input.

      This appears in 2.3 and the latest master (2.4 beta).

        Gliffy Diagrams

          Issue Links

            Activity

            damyon Damyon Wiese added a comment -

            The quickgrading checkbox is missing the ignoredirty class.

            damyon Damyon Wiese added a comment -

            Hi Michael,

            I can't reproduce this on 2.3 - only on 2.4dev - can you confirm that this is happening for you on 2.3?

            Thanks

            damyon Damyon Wiese added a comment -

            Never mind - I can get it to happen on 2.3.

            poltawski Dan Poltawski added a comment -

            Integrated, thanks.

            ankit_frenz Ankit Agarwal added a comment -

            Works as described.
            Thanks

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Many thanks for your effort, the whole Moodle Community will be enjoying your great solutions starting now!

            Closing, ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/Jan/13