Moodle
  1. Moodle
  2. MDL-37033

Decide Moodle 2.5 requirements and push them to environment.xml

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2.6, 2.3.3, 2.4, 2.5
    • Fix Version/s: 2.2.10, 2.3.7, 2.4.4
    • Component/s: Installation
    • Labels:
    • Testing Instructions:
      Hide

      0) To test exclusively in stable branches (from 22 to 24)
      1) Go to admin -> server -> environment
      2) One "2.5 upwards" Moodle version should be available
      3) It shows the same requirements than a 2.4 version but with these differences:

      a) php 5.3.3 is required (versus 5.3.2 in 2.4).
      b) gd extension is required (versus recommended in 2.4).

      Show
      0) To test exclusively in stable branches (from 22 to 24) 1) Go to admin -> server -> environment 2) One "2.5 upwards" Moodle version should be available 3) It shows the same requirements than a 2.4 version but with these differences: a) php 5.3.3 is required (versus 5.3.2 in 2.4). b) gd extension is required (versus recommended in 2.4).
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • Pull from Repository:
    • Pull 2.4 Branch:
    • Pull Master Branch:
    • Rank:
      46573

      Description

      We need to decide ASAP about all the PHP/DB/Moodle versions requirements and put all them into the environmental tests (adding them to all supported branches).

      At the same time, if there is any change in the PHP version... some changes have to be populated to various installers and replace them by the new one when corresponding. To get a list of candidates:

      grep -r '5\.3\.3' * | grep '\.php'

      (and look for MDL-39007 status, about to unify all those duplicated checks)

      Ciao

        Issue Links

          Activity

          Hide
          Petr Škoda added a comment -

          +1 for PHP 5.3.3 requirement because 5.2.2 is nasty and will not be testable via phpunit 3.7.x

          Show
          Petr Škoda added a comment - +1 for PHP 5.3.3 requirement because 5.2.2 is nasty and will not be testable via phpunit 3.7.x
          Hide
          Petr Škoda added a comment -

          oh, http://php.net/manual/en/function.get-html-translation-table.php
          we should really go for at least 5.3.4 to get full utf-8 support everywhere

          Show
          Petr Škoda added a comment - oh, http://php.net/manual/en/function.get-html-translation-table.php we should really go for at least 5.3.4 to get full utf-8 support everywhere
          Hide
          Dan Poltawski added a comment -

          I've added two links to this issue.

          MDL-35332 - php 5.3.7+ would make (bcypt passwords) more straight forward
          MDL-34331 - Making GD a required extension. It is used for thumbnails and graphs at the moment and every now and again bugs popup for people without it.

          Show
          Dan Poltawski added a comment - I've added two links to this issue. MDL-35332 - php 5.3.7+ would make (bcypt passwords) more straight forward MDL-34331 - Making GD a required extension. It is used for thumbnails and graphs at the moment and every now and again bugs popup for people without it.
          Hide
          Petr Škoda added a comment -

          And now the horror stories:

          • Squeeze has only PHP 5.3.3, to be supported for at least one more year
          • RHEL 6.3 has PHP 5.3.3 too
          Show
          Petr Škoda added a comment - And now the horror stories: Squeeze has only PHP 5.3.3, to be supported for at least one more year RHEL 6.3 has PHP 5.3.3 too
          Hide
          Eloy Lafuente (stronk7) added a comment -

          ping we need to decide about this asap!

          Note that apparently 5.3.10 is having problems with some zips (MDL-37429) and 5.3.15 seems to have it fixed. Petr says he will try to fix it "harcoding brute workarounds", or something like that, lol.

          It's a shame how delayed (and unsafe, unsecure) are official distros with PHP (I know we cannot raise to 5.3.15, grrr).

          Consider yourself pinged!

          Show
          Eloy Lafuente (stronk7) added a comment - ping we need to decide about this asap! Note that apparently 5.3.10 is having problems with some zips ( MDL-37429 ) and 5.3.15 seems to have it fixed. Petr says he will try to fix it "harcoding brute workarounds", or something like that, lol. It's a shame how delayed (and unsafe, unsecure) are official distros with PHP (I know we cannot raise to 5.3.15, grrr). Consider yourself pinged!
          Hide
          Dan Poltawski added a comment -
          Show
          Dan Poltawski added a comment - fyi: https://wiki.php.net/rfc/php53eol
          Hide
          Petr Škoda added a comment -

          we should probably bump up PHP requirement to 5.3.3, it seems that all other big projects require this ancient version which is in debian and centos/redhat

          Show
          Petr Škoda added a comment - we should probably bump up PHP requirement to 5.3.3, it seems that all other big projects require this ancient version which is in debian and centos/redhat
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Side note, perhaps we should start requiring sqlsrv 3.0.1 too (custom, conditional test?). Older versions are troublemakers (see MDL-37748).

          Show
          Eloy Lafuente (stronk7) added a comment - Side note, perhaps we should start requiring sqlsrv 3.0.1 too (custom, conditional test?). Older versions are troublemakers (see MDL-37748 ).
          Hide
          Petr Škoda added a comment -

          I would vote to add a new warning to the environment test - look for builddate or php binary date and warn if older than 3-6 months.

          Show
          Petr Škoda added a comment - I would vote to add a new warning to the environment test - look for builddate or php binary date and warn if older than 3-6 months.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Seems PHP 5.3.3 + GD required are the only changes to perform for 2.5

          Let's try to reconsider new checks better for 2.6.

          Show
          Eloy Lafuente (stronk7) added a comment - Seems PHP 5.3.3 + GD required are the only changes to perform for 2.5 Let's try to reconsider new checks better for 2.6.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Thanks Helen for reviewing my stringlish.

          Show
          Eloy Lafuente (stronk7) added a comment - Thanks Helen for reviewing my stringlish.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Sending to integration, no matter this is not a security issue we always use to spread them to all supported versions so 22_STABLE branch is included (note that normally we do it way earlier).

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Sending to integration, no matter this is not a security issue we always use to spread them to all supported versions so 22_STABLE branch is included (note that normally we do it way earlier). Ciao
          Hide
          Damyon Wiese added a comment -

          Thanks Eloy - integrated to 22, 23, 24 and master.

          I added one commit to change the indenting in the xml to match the rest of the file.

          Show
          Damyon Wiese added a comment - Thanks Eloy - integrated to 22, 23, 24 and master. I added one commit to change the indenting in the xml to match the rest of the file.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          thanks for fixing the indent, still don't understand how it finished there, I remember myself copying and pasting lines with vim.

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - thanks for fixing the indent, still don't understand how it finished there, I remember myself copying and pasting lines with vim. Ciao
          Hide
          Jason Fowler added a comment -

          Sweet, apparently my machine can run Moodle 2.5 Passing test Eloy.

          Show
          Jason Fowler added a comment - Sweet, apparently my machine can run Moodle 2.5 Passing test Eloy.
          Hide
          Damyon Wiese added a comment -

          Thanks for your hard work. This issue has been integrated upstream and is now available via git (and in some hours, via mirrors and downloads).

          Show
          Damyon Wiese added a comment - Thanks for your hard work. This issue has been integrated upstream and is now available via git (and in some hours, via mirrors and downloads).
          Hide
          Séverin Terrier added a comment - - edited

          I've just (now) tried in a Moodle 2.3.6, from "Site Administration > Server > Environment" to "Update component" and it says "Component is up-to-date", but there's nothing about Moodle 2.5 in the component i have...
          Should'nt there be something updated on Moodle.org server, to allow every Moodle admins to update component on existing instances (even from older versions) ?

          Show
          Séverin Terrier added a comment - - edited I've just (now) tried in a Moodle 2.3.6, from "Site Administration > Server > Environment" to "Update component" and it says "Component is up-to-date", but there's nothing about Moodle 2.5 in the component i have... Should'nt there be something updated on Moodle.org server, to allow every Moodle admins to update component on existing instances (even from older versions) ?
          Hide
          Séverin Terrier added a comment -
          Show
          Séverin Terrier added a comment - I've created MDLSITE-2177 to update http://download.moodle.org/environment/environment.zip

            People

            • Votes:
              1 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: