Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-37041

The LTI consumer does not pass the user's profile picture in the user_image launch parameter

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      You will need two moodle instances.

      1. On site A, share a course or tool using the LTI provider
      2. On site B, add the tool via cartridge and copy the secret
      3. Create an external tool using that configuration and check that your user image is shown inside the iframe
      4. Add a tool via the proxy url
      5. Create an external tool using that configuration and check that your user image is shown inside the iframe
      6. Turn the privacy setting on and off and make sure it is respected
      Show
      You will need two moodle instances. On site A, share a course or tool using the LTI provider On site B, add the tool via cartridge and copy the secret Create an external tool using that configuration and check that your user image is shown inside the iframe Add a tool via the proxy url Create an external tool using that configuration and check that your user image is shown inside the iframe Turn the privacy setting on and off and make sure it is respected
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_30_STABLE, MOODLE_31_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-37041-master

      Description

      The LTI consumer does not pass the user's profile picture in the user_image launch parameter. Users will think they have suddenly lost their profile image.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: