Details

    • Testing Instructions:
      Hide

      Test to make sure nothing has changed with modchooser toggle

      1. Create course in topics or weeks format
      2. Enter editing mode and make sure you can toggle modchooser in course settings menu
      3. Create course in social format
      4. Enter editing mode and make sure you can not toggle modchooser in course settings menu
      5. Login as a student and make sure you don't see modchoosertoggle and there are no errors
      Show
      Test to make sure nothing has changed with modchooser toggle Create course in topics or weeks format Enter editing mode and make sure you can toggle modchooser in course settings menu Create course in social format Enter editing mode and make sure you can not toggle modchooser in course settings menu Login as a student and make sure you don't see modchoosertoggle and there are no errors
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull Master Branch:
      wip-MDL-37207-master
    • Rank:
      46798

      Description

      Now when print_section() is moved to the course renderer, the theme may decide not to use modchooser at all. This means theme does not need modchooser toggle menu item in course navigation. It may help to add the modchoosertoggle element inside the course renderer so theme can overwrite not to use it.

        Issue Links

          Activity

          Hide
          Marina Glancy added a comment -

          TO INTEGRATORS: master only

          Show
          Marina Glancy added a comment - TO INTEGRATORS: master only
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Moving this out from current integration because blocker of this (MDL-37206) has been reopened.

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Moving this out from current integration because blocker of this ( MDL-37206 ) has been reopened. Ciao
          Hide
          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Show
          Eloy Lafuente (stronk7) added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Integrated (master only), thanks!

          Show
          Eloy Lafuente (stronk7) added a comment - Integrated (master only), thanks!
          Hide
          Michael de Raadt added a comment - - edited

          I am presented with the following error when logged in as a student in a course on the course page.

          Navigation node add_before: Reference node not found editsettings, options: grades
          line 752 of \lib\navigationlib.php: call to debugging()
          line 322 of \lib\navigationlib.php: call to navigation_node_collection->add()
          line 89 of \course\renderer.php: call to navigation_node->add_node()
          line 52 of \course\renderer.php: call to core_course_renderer->add_modchoosertoggle()
          line 240 of \lib\outputfactories.php: call to core_course_renderer->__construct()
          line 1290 of \lib\outputlib.php: call to standard_renderer_factory->get_renderer()
          line 754 of \lib\pagelib.php: call to theme_config->get_renderer()
          line 52 of \course\format\renderer.php: call to moodle_page->get_renderer()
          line 240 of \lib\outputfactories.php: call to format_section_renderer_base->__construct()
          line 1290 of \lib\outputlib.php: call to standard_renderer_factory->get_renderer()
          line 754 of \lib\pagelib.php: call to theme_config->get_renderer()
          line 135 of \course\view.php: call to moodle_page->get_renderer()
          line 754 of \lib\pagelib.php: call to theme_config->get_renderer()
          line 135 of \course\view.php: call to moodle_page->get_renderer()
          
          Show
          Michael de Raadt added a comment - - edited I am presented with the following error when logged in as a student in a course on the course page. Navigation node add_before: Reference node not found editsettings, options: grades line 752 of \lib\navigationlib.php: call to debugging() line 322 of \lib\navigationlib.php: call to navigation_node_collection->add() line 89 of \course\renderer.php: call to navigation_node->add_node() line 52 of \course\renderer.php: call to core_course_renderer->add_modchoosertoggle() line 240 of \lib\outputfactories.php: call to core_course_renderer->__construct() line 1290 of \lib\outputlib.php: call to standard_renderer_factory->get_renderer() line 754 of \lib\pagelib.php: call to theme_config->get_renderer() line 52 of \course\format\renderer.php: call to moodle_page->get_renderer() line 240 of \lib\outputfactories.php: call to format_section_renderer_base->__construct() line 1290 of \lib\outputlib.php: call to standard_renderer_factory->get_renderer() line 754 of \lib\pagelib.php: call to theme_config->get_renderer() line 135 of \course\view.php: call to moodle_page->get_renderer() line 754 of \lib\pagelib.php: call to theme_config->get_renderer() line 135 of \course\view.php: call to moodle_page->get_renderer()
          Hide
          Marina Glancy added a comment -

          Thanks Michael. I added commit fixing it

          Show
          Marina Glancy added a comment - Thanks Michael. I added commit fixing it
          Hide
          Rajesh Taneja added a comment -

          Thanks Marina,

          Requested Dan to pull this.

          Show
          Rajesh Taneja added a comment - Thanks Marina, Requested Dan to pull this.
          Hide
          Dan Poltawski added a comment -

          Pulled the fix in.

          Show
          Dan Poltawski added a comment - Pulled the fix in.
          Hide
          Rajesh Taneja added a comment -

          Sorry Marina,

          I am failing this test because of one minor accessibility problem.

          1. Link title and image alt-text is not changing with change in link. This is same in master_stable, but seems it can be fixed in this bug. Let me know if you think otherwise and I will pass it.

          Not sure what I am missing:

          1. In social format I can't see "Activity chooser" link. (Test instructions - Step 4)
          Show
          Rajesh Taneja added a comment - Sorry Marina, I am failing this test because of one minor accessibility problem. Link title and image alt-text is not changing with change in link. This is same in master_stable, but seems it can be fixed in this bug. Let me know if you think otherwise and I will pass it. Not sure what I am missing: In social format I can't see "Activity chooser" link. (Test instructions - Step 4)
          Hide
          Dan Poltawski added a comment -

          Ping.

          Show
          Dan Poltawski added a comment - Ping.
          Hide
          Marina Glancy added a comment -

          Dan, I PMed you about this issue (and forgotten commit in MDL-37085 as well) and you did not reply to any of them. Guess I'd better write everything in the comments.

          The testing instructions say "ensure nothing is changed in UI". And Raj failed the test because he expects changes. I think that separate issue needs to be created for improvement

          (Raj, about social format - there should not be any link as well as there is not now, before this issue)

          Show
          Marina Glancy added a comment - Dan, I PMed you about this issue (and forgotten commit in MDL-37085 as well) and you did not reply to any of them. Guess I'd better write everything in the comments. The testing instructions say "ensure nothing is changed in UI". And Raj failed the test because he expects changes. I think that separate issue needs to be created for improvement (Raj, about social format - there should not be any link as well as there is not now, before this issue)
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Thanks, Mar!

          Raj, would you create the discovered when testing issue, so we can happily close this and roll & rock? TIA!

          PS: Dan, Mar, Raj... Elo, lol, ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Thanks, Mar! Raj, would you create the discovered when testing issue, so we can happily close this and roll & rock? TIA! PS: Dan, Mar, Raj... Elo, lol, ciao
          Hide
          Marina Glancy added a comment -

          lol Elo, now i have a new name

          Show
          Marina Glancy added a comment - lol Elo, now i have a new name
          Hide
          Rajesh Taneja added a comment -

          Thanks everyone,

          I have created MDL-37574 to resolve title and alt-text issue.
          Please feel free to pass it or re-open it for testing and I will pass it.

          Show
          Rajesh Taneja added a comment - Thanks everyone, I have created MDL-37574 to resolve title and alt-text issue. Please feel free to pass it or re-open it for testing and I will pass it.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Passed (on behalf of Raj)

          Show
          Eloy Lafuente (stronk7) added a comment - Passed (on behalf of Raj)
          Hide
          Rajesh Taneja added a comment -

          Thanks Eloy

          Show
          Rajesh Taneja added a comment - Thanks Eloy
          Hide
          Dan Poltawski added a comment -

          Dan, I PMed you about this issue (and forgotten commit in MDL-37085 as well) and you did not reply to any of them. Guess I'd better write everything in the comments.

          Yes, please do, it makes it possible for any of the integrators to take over, and when there are 20+ failed issues it gets confusing!

          Show
          Dan Poltawski added a comment - Dan, I PMed you about this issue (and forgotten commit in MDL-37085 as well) and you did not reply to any of them. Guess I'd better write everything in the comments. Yes, please do, it makes it possible for any of the integrators to take over, and when there are 20+ failed issues it gets confusing!
          Hide
          Dan Poltawski added a comment -

          Hurray! We did it! Thanks to all the reporters, testers, user and watchers for a bumper week of Moodling!

          Show
          Dan Poltawski added a comment - Hurray! We did it! Thanks to all the reporters, testers, user and watchers for a bumper week of Moodling!

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: