Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.1
    • Fix Version/s: 1.8.3, 1.9
    • Component/s: Quiz
    • Labels:
      None
    • Environment:
      All
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_15_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Rank:
      27594

      Description

      In the Item Analysis Table the last column called Disc.

      Coeff. shows numbers like -999.00. From the help file I read the range is -1 to 1.

        Activity

        Martin Dougiamas added a comment -

        From Jean_Michel Vedrine (jean-michel.vedrine at wanadoo.fr) Thursday, 28 July 2005, 12:51 AM:

        Well this is in fact not a bug in the code, but this help file doesn't speak about a very special case.

        excerpt from the help file:

        The discrimination coefficient is a correlation coefficient between scores at the item and at the whole quiz. Here it is calculated as:

        DC = Sum(xy)/ (N * sx * sy)

        where Sun(xy) is the sum of the products of deviations for item scores and overall quiz scores,

        N is the number of responses given to this question

        sx is the standard deviation of fractional scores for this question and,

        sy is the standard deviation of scores at the quiz as a whole.

        Now imagine that all student gave the same response to this question, then sx = 0 and we have a divide by zero operation and DC is infinity. In that case by design -999 is displayed.

        So to close that bug, all we need is to rewrite the help file

        Tim Hunt added a comment -

        Help file revised to explain the DC = -999 case.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: