Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-37378

Notice Undefined property timecheckstate when restoring old backups

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.3.5, 2.4.2
    • Component/s: Quiz
    • Labels:
      None
    • Testing Instructions:

      1. Backup a course including quiz attempt from Moodle 2.0, 2.1 or 2.2.

      2. Restore into Moodle 2.3 or later.

      3. Verify that there are no errors, warnings or notices.

      Show
      1. Backup a course including quiz attempt from Moodle 2.0, 2.1 or 2.2. 2. Restore into Moodle 2.3 or later. 3. Verify that there are no errors, warnings or notices.
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      Restoring a 2.0 backup in Moodle 2.4 produce:
      Notice: Undefined property: stdClass::timecheckstate in C:\wamp\www\moodle_test\mod\quiz\backup\moodle2\restorequizstepslib.php on line309
      Most likely a regression caused by MDL-35717.

        Gliffy Diagrams

          Issue Links

            Activity

            timhunt Tim Hunt added a comment -

            I think this fixes it. Jean-Michel, are you able to verify that? Thanks.

            ankit_frenz Ankit Agarwal added a comment -

            Hi Tim,
            The patch looks good.
            I was looking to see what happens in apply_date_offset() for a value of 0, just to make sure if empty or isset check will make more sense. But it doesn't really matter here.

            So please feel free to submit for integration.
            Thanks

            timhunt Tim Hunt added a comment -

            Thanks Ankit. Submitting for integration.

            jmvedrine Jean-Michel Vedrine added a comment -

            Hello Tim,
            Sorry I didn't saw your message because I was receiving any notifications since JIRA upgrade but they are working again now. Your fix solve the problem for me. Thanks.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            samhemelryk Sam Hemelryk added a comment -

            Thanks guys, this has been integrated now.

            abgreeve Adrian Greeve added a comment -

            Tested on 2.3, 2.4 and master integration branches.
            No errors, warnings or notices.
            Test passed.

            poltawski Dan Poltawski added a comment -

            Hurray! We did it! Thanks to all the reporters, testers, user and watchers for a bumper week of Moodling!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Mar/13