Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-37394

Launch Failure for AICC Direct URL

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4.2
    • Component/s: SCORM
    • Labels:
    • Testing Instructions:

      go to admin > plugins > activity modules > SCORM
      make sure the setting "Enable direct AICC url" is set to "yes"

      Create a new SCORM in your site - select the scormtype "external AICC URL" and use the following url:
      http://3rdparty.skillwsa.com/olsa/ro?customerId=sp3rdparty&course_id=mo_olpu_a02_dt_enus&access_mode=aicc&HACP=1&olsa_cvs_value=mpKKpv4jOqu6yh0

      Enter the SCORM and the content should be loaded in the TOC - (note that the TOC is useless when using directurl so will be empty -usually the teacher will hide/disable it in the SCORM settings page. - see MDL-37484 for an improvement related to this)

      Show
      go to admin > plugins > activity modules > SCORM make sure the setting "Enable direct AICC url" is set to "yes" Create a new SCORM in your site - select the scormtype "external AICC URL" and use the following url: http://3rdparty.skillwsa.com/olsa/ro?customerId=sp3rdparty&course_id=mo_olpu_a02_dt_enus&access_mode=aicc&HACP=1&olsa_cvs_value=mpKKpv4jOqu6yh0 Enter the SCORM and the content should be loaded in the TOC - (note that the TOC is useless when using directurl so will be empty -usually the teacher will hide/disable it in the SCORM settings page. - see MDL-37484 for an improvement related to this)
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull Master Branch:
      master_MDL-37394

      Description

      Content loaded using the new AICC Direct URL option fails to load.

      STEPS TO REPRODUCE
      1. Enable direct AICC URL
      2. Create new SCORM activity and use this url

      http://3rdparty.skillwsa.com/olsa/ro?customerId=sp3rdparty&course_id=mo_olpu_a02_dt_enus&access_mode=aicc&HACP=1&olsa_cvs_value=mpKKpv4jOqu6yh0

      The TOC in the SCORM player us not correctly displayed and the course fails to load generating a JavaScript error

        Gliffy Diagrams

          Issue Links

            Activity

            martin_holden@skillsoft.com Martin Holden added a comment -

            I believe this issue is related to the TOC generation issue

            martin_holden@skillsoft.com Martin Holden added a comment -

            AICC URL Launch JavaScript error and NO TOC

            martin_holden@skillsoft.com Martin Holden added a comment -

            Same URL used in Moodle 2.3.2 without issue

            danmarsden Dan Marsden added a comment -

            bouncing up for integration - note this is for 2.4 and master only - it is not an issue in 2.3

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            samhemelryk Sam Hemelryk added a comment -

            Thanks Dan, this has been integrated now

            ankit_frenz Ankit Agarwal added a comment -

            Hi Dan,
            Am not sure I understand the testing instructions properly

            the content should be loaded in the TOC - (note that the TOC is useless when using directurl so will be empty

            Does that mean something should be loaded in the TOC or not?

            at present TOC is empty for me.

            Thanks

            danmarsden Dan Marsden added a comment -

            hey - TOC empty is either "correct behaviour" or a different bug - I'm thinking of disabling the TOC completely when using Direct URL which makes it closer to "Correct behaviour" - see MDL-37484

            ankit_frenz Ankit Agarwal added a comment -

            Thanks Dan for explaining.
            Passing as content is loading
            Thanks

            poltawski Dan Poltawski added a comment -

            Hurray! We did it! Thanks to all the reporters, testers, user and watchers for a bumper week of Moodling!

            rezaie9 Shamim Rezaie added a comment - - edited

            Hi

            The 3 lines that were added to player.js to fix this issue are not present in the latest 2.4.1.
            Is that because the problem is sorted out in another way or maybe because of some mistake?

            rezaie9 Shamim Rezaie added a comment -

            please ignore my last comment as it's totally rubbish
            sorry


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Mar/13