Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-37414

Re-add the ability to add certain blocks to the My Moodle page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4.2
    • Component/s: Blocks, My home
    • Labels:
    • Testing Instructions:
      1. Log in as an admin.
      2. Visit <yoursite>/my
      3. Ensure you can add the following blocks.
        • Random glossary entry
        • Mentees
        • Latest news
        • Online users
      4. Visit <yoursite>/admin/roles/define.php?action=edit&roleid=5
      5. Ensure the myaddinstance capabilities for the above blocks are translated.
      Show
      Log in as an admin. Visit <yoursite>/my Ensure you can add the following blocks. Random glossary entry Mentees Latest news Online users Visit <yoursite>/admin/roles/define.php?action=edit&roleid=5 Ensure the myaddinstance capabilities for the above blocks are translated.
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull Master Branch:
      MDL-37414_master

      Description

      From Wendell's comment in MDL-36455, I realise it was a mistake to remove the option to add the online users block to My home (My Moodle). Thus I think the change should be reverted and the capability block/online users:myaddinstance re-added.

      At the same time, let's re-assess whether there is actually a case for adding the other blocks mentioned in MDL-36455 to My home.

      • Would the Latest news block display the site news?
      • Would the Random glossary entry block use entries from a front page glossary, or a global glossary?
      • Would the Course/site description block display the site description (perhaps an admin may wish to force this block to display)?
      • Would the mentees block work on the My home page for users with the role of mentor?

      Can anyone think of any reasons for adding Course completion status and Self completion to My home?

        Gliffy Diagrams

          Issue Links

            Activity

            marycooch Mary Cooch added a comment -

            On the school demo site, with the parent login, the mentees block is available and works very well.Similarly I added the Latest news block and the site description to the parent's My home and they displayed as you would expect. I haven't tried with a global glossary for the random glossary block however.

            markn Mark Nelson added a comment -

            I tested the random glossary block on the My Moodle page and it does work, I can see some people using this.

            Current list of blocks that will be re-added that were removed.

            1. glossary_random
            2. mentees
            3. news_items
            4. online_users

            This means that only the following blocks will not be available on the My Moodle page due to MDL-36455

            1. completionstatus
            2. course_summary
            3. selfcompletion

            damyon Damyon Wiese added a comment -

            Thanks Mark - here is your checklist:

            [Y] Syntax
            [Y] Output
            [Y] Whitespace
            [Y] Language - I checked on dev chat to see if we could revive the deleted language strings. David Mudrak said we can't
            [-] Databases
            [Y] Testing
            [-] Security
            [-] Documentation
            [Y] Git
            [Y] Sanity check

            All good - sending for integration.

            stronk7 Eloy Lafuente (stronk7) added a comment - - edited

            Sorry, I'm failing this.

            If I'm not wrong, in MDL-36455 some upgrade code was introduced to take rid of all the "offending" blocks from the "my" page.

            If here we are reverting the status of some of those blocks to "non-offending", then for sure the upgrade code commented above should disappear too (or we'll continue deleting everybody's "old-offending" on upgrade).

            Otherwise it looks ok, I think. Basically a selective "revert" of the non-offending blocks.

            Ciao

            cibot CiBoT added a comment -

            Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.

            markn Mark Nelson added a comment -

            Hi Eloy, I wasn't sure what the policy was with deleting upgrade code, so left it. Though, since this was a regression we do not want users who upgrade to 2.4 now to lose those blocks that should not be removed, so removing the code does make sense. I have amended my commit. Thanks.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            samhemelryk Sam Hemelryk added a comment -

            Thanks Mark, this has been integrated now.

            andyjdavis Andrew Davis added a comment -

            Works as described. Passing.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            A brilliant future is awaiting us out there, better with your code. Let's look towards the future together, this is now closed.

            (and won't be revisiting it unless some regression is found)

            Thanks and ciao

            koen Koen Roggemans added a comment -

            Note that My Moodle page is renamed to My home page

            marycooch Mary Cooch added a comment -

            Removing docs_required label as I have updated the My home page http://docs.moodle.org/24/en/My_home


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Mar/13