Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-37453

Hide/show edit icon does not change the label classes when using AJAX

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4, 2.5
    • Fix Version/s: 2.4.2
    • Component/s: Course
    • Labels:
    • Testing Instructions:
      1. Create course in topics/weeks format (where AJAX is enabled)
      2. Create label and some other activity
      3. In edit mode click on icon hide/show (eye) next to label and other activity
      4. Make sure the label text dims/becomes normal as well as it does in other activity
      5. Change the availability of label and other activity so they are not available now (for example, available after future date)
      6. Go to course page and click show/hide icon, make sure that text remains dimmed
      Show
      Create course in topics/weeks format (where AJAX is enabled) Create label and some other activity In edit mode click on icon hide/show (eye) next to label and other activity Make sure the label text dims/becomes normal as well as it does in other activity Change the availability of label and other activity so they are not available now (for example, available after future date) Go to course page and click show/hide icon, make sure that text remains dimmed
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull Master Branch:
      wip-MDL-37453-master

      Description

      1. Create course in topics/weeks format (where AJAX is enabled), add label and some other activity
      2. In edit mode click on icon hide/show (eye) next to label and other activity
      3. the label text is supposed to dim/become normal but it does not

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              marina Marina Glancy added a comment -

              This is regression from MDL-36550 where new div was added in print_section() line 1488:

              echo html_writer::start_tag('div', array('class' => 'activityinstance'));
              

              This div is empty for label but JavaScript tries to toggle it's class instead of content

              marina Marina Glancy added a comment -

              TO INTEGRATORS: please cherry-pick to 2.4

              stronk7 Eloy Lafuente (stronk7) added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              stronk7 Eloy Lafuente (stronk7) added a comment -

              I don't understand a word but integrated (24 & master), thanks!

              samhemelryk Sam Hemelryk added a comment -

              All looks good to me

              fred Frédéric Massart added a comment -

              Sorry, failing because that does not seem to work. I noticed that the problem was probably that is_label() does not work any more. It could still be a regression created by MDL-36550 because I removed $mod->extra. To investigate!

              poltawski Dan Poltawski added a comment -

              Ping.

              marina Marina Glancy added a comment -

              ups, this was a bug in MDL-37085 in the same integration. Fixed it under other issue

              poltawski Dan Poltawski added a comment -

              Fred, back to testing, think this can be passed?

              marina Marina Glancy added a comment -

              Fred wait, fix has not been integrated yet

              poltawski Dan Poltawski added a comment -

              Where is the fix???§

              poltawski Dan Poltawski added a comment -

              Apparently it was 8df0765ad14267505fe07fb2f3da481c8cabf9cc in MDL-37085. Fred, can you re-test, thanks

              fred Frédéric Massart added a comment -

              Test passed. Thanks!

              poltawski Dan Poltawski added a comment -

              Hurray! We did it! Thanks to all the reporters, testers, user and watchers for a bumper week of Moodling!


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Mar/13