Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-37515

PHP Notice when submitting change password form

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Authentication
    • Labels:
    • Testing Instructions:

      Testing difficulty: easy

      1. Login to Moodle
      2. Turn debugging to DEVELOPER level
      3. Click Administration > My profile settings > Change password
      4. Fill out the form and submit: no warning is displayed
      Show
      Testing difficulty: easy Login to Moodle Turn debugging to DEVELOPER level Click Administration > My profile settings > Change password Fill out the form and submit: no warning is displayed
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      m25_MDL-37515_Notice_when_submitting_change_password_form

      Description

      Steps to reproduce:

      1. Login to site
      2. Turn debugging to developer level
      3. Click My Profile Settings > Change Password
      4. Fill out the form and submit

      What happens:

      After submitting the change password form I get:

      Notice: Undefined variable: user in /home/simonc/code/mdl22/login/change_password.php on line 115

      The password is successfully changed though.

      What should happen:

      No warning should be displayed.

      Seems to be due to this patch:

      https://tracker.moodle.org/browse/MDL-21342

        Gliffy Diagrams

          Issue Links

            Activity

            salvetore Michael de Raadt added a comment -

            Thanks for reporting that, Simon.

            matteo Matteo Scaramuccia added a comment -

            Ping

            skodak Petr Skoda added a comment -

            +1, submitting for integration

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated (master only), thanks!

            rwijaya Rossiani Wijaya added a comment -

            This works as expected.

            Tested for Master only.

            Test passed.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            This is valid for unlimited entries to the, soon to be unveiled, Moodle Codebase Gardens. It includes free access to all facilities.

            Personal and non-transferable to all assignees, reviewers and testers in this issue. Valid until switching to Blackboard (100000€ penalization will be applied).

            Thanks, closing as fixed!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/May/13