Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-37564

plugin dependency check does not link to moodle.org/plugins for easier downloading

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4.1, 2.4.5, 2.5.1
    • Fix Version/s: 2.4.6, 2.5.2
    • Component/s: Administration
    • Labels:
    • Testing Instructions:

      1) install any plugin that has a dependency. (do not install the dependency).

      e.g. https://moodle.org/plugins/view.php?plugin=assignfeedback_pdf

      2) got to admin/index.php, you will get a plugin dependency check screen that mentions the required plugin (dependency). Check that the original frankenstyle is now a link to the plugins DB to download that plugin.

      Show
      1) install any plugin that has a dependency. (do not install the dependency). e.g. https://moodle.org/plugins/view.php?plugin=assignfeedback_pdf 2) got to admin/index.php, you will get a plugin dependency check screen that mentions the required plugin (dependency). Check that the original frankenstyle is now a link to the plugins DB to download that plugin.
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE

      Description

      This is a quick link to allow easier installation of a plugin that isn't installed at all yet.

      this will be more easier in future in line with evolving plugin deployment development.

      this should be backportable for now into stables.

        Gliffy Diagrams

          Attachments

            Activity

            nebgor Aparup Banerjee added a comment -

            patches up. peer-reviewer please put this up for integration if its fine.

            nebgor Aparup Banerjee added a comment -

            asking David for a review. afaik David's working on the related actual new plugin installation.

            nebgor Aparup Banerjee added a comment -

            anyone else can feel free too peer-review too.

            ankit_frenz Ankit Agarwal added a comment -

            Hi,
            Aparup, The change makes sense. However I suggest a few minor things:-

            1. _blank for the url so, it opens in a new tab
            2. Please add a link to one such plugin that can be used in testing instructions.

            As we discussed if there is a standard plugin which is required and is not present, this will link to an error page. It will also link to the error page if a add-on is required but not present in the plugins dir.

            But we might have to live with it.

            Thanks

            nebgor Aparup Banerjee added a comment -

            this fell off the radar totally

            damyon Damyon Wiese added a comment -

            Thanks Aparup,

            I would consider this a bug, and this seems safe, so I've integrated it for stables.

            Integrated to 24, 25 and master.

            marina Marina Glancy added a comment -

            This works but link opens in the same window. Is this expected behaviour? Looking through the comments seems that you discussed it

            ankit_frenz Ankit Agarwal added a comment - - edited

            my +1 for new window/tab

            poltawski Dan Poltawski added a comment - - edited

            Hi,

            I don't think this blocks us releasing so i'm passing this. (can you create a new issue).

            [side note] Especially because creating a new window under XHTML involves JS because it doesn't have _target. Actually I think in 2.4 might be where we moved to html5 doctype, so perhaps we can now use _target again and not mess around with this stuff.

            nebgor Aparup Banerjee added a comment -

            actually with the work flow here, you should go into the plugins directory page, hit the install button there and come right back into your moodle site. so not 100% need to force new window/tab, user (an administrator of moodle!) can always right click.

            poltawski Dan Poltawski added a comment -

            Congratulations! This change has been integrated upstream and is now available from our git and download mirrors. To celebrate, here is a joke:

            A SQL query goes into a bar, walks up to two tables and asks, "Can I join you?"


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  9/Sep/13