Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-37713

phpunit bootstrap does not create dataroot dir if missing

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.4, 2.4.1, 2.5
    • Fix Version/s: 2.3.5, 2.4.2
    • Component/s: Unit tests
    • Labels:
      None
    • Testing Instructions:

      1/ set some non-existent $CFG->phpunit_dataroot in your config.php (make sure you have permissions to create the dir)
      2/ run phpunit init
      3/ verify the directory was created

      Show
      1/ set some non-existent $CFG->phpunit_dataroot in your config.php (make sure you have permissions to create the dir) 2/ run phpunit init 3/ verify the directory was created
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w04_MDL-37713_m25_testdir

      Description

      This is a regression caused by MDL-37555, the real_path() returns false if dir does not exist yet.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              samhemelryk Sam Hemelryk added a comment -

              Thanks Petr, this has been integrated now.

              rwijaya Rossiani Wijaya added a comment -

              This works as expected.

              Tested for 2.3, 2.4 and master.

              Test passed.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              A brilliant future is awaiting us out there, better with your code. Let's look towards the future together, this is now closed.

              (and won't be revisiting it unless some regression is found)

              Thanks and ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Mar/13