Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-37966

Assignments appear at the end of each section after upgrading from "Assignments 2.2"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4.4
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:

      1. Create an "Assignment 2.2" in a section with more activities and move to top of the section.
      2. Execute "Assignment upgrade helper" process to migrate this assignment.
      3. Access to the course to check that the assignment has been upgrated correctly but also has been moved to the end of the section.

      Show
      1. Create an "Assignment 2.2" in a section with more activities and move to top of the section. 2. Execute "Assignment upgrade helper" process to migrate this assignment. 3. Access to the course to check that the assignment has been upgrated correctly but also has been moved to the end of the section.
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      After ugprading "Assignments 2.2" to "Assignment" with the "Assignment upgrade helper" tool all the migrated assignments appear at the end of the section where they were included (so the position of the migrated assessment is modified always after executing the upgrading process).

        Gliffy Diagrams

          Activity

          damyon Damyon Wiese added a comment -

          Thanks for reporting this.

          I've put that on the backlog.

          In the meantime feel free to help us work on this issue. If you are able to provide a patch or links to your Git repository branch, please add a patch label so we will spot it.

          jonof Jonathon Fowler added a comment - - edited

          Here's a fix for master. If you want a 2.4 branch then I'll prepare one too.

          Edit: did a 2.4 branch anyway.

          jsouthcombe Jennifer southcombe added a comment -

          I ran into this issue and have stopped upgrading assignments as this creates a lot of extra work reorganizing lots of assignments. Hope someone can help fix this.

          paul.n Paul Nicholls added a comment -

          Assigning to Jonathon since the pull details are for his repo.

          paul.n Paul Nicholls added a comment -

          All looks good to me. We've got this patch running on our production system, and it works well.

          [Y] Syntax
          [-] Output
          [Y] Whitespace
          [-] Language
          [-] Databases
          [Y] Testing
          [-] Security
          [-] Documentation
          [Y] Git
          [Y] Sanity check

          paul.n Paul Nicholls added a comment -

          Damyon Wiese, are you able to put this up for integration review? I don't have permission to do so.

          Cheers,
          Paul

          damyon Damyon Wiese added a comment - - edited

          Note for integrators: The patch looks good. The bug does not apply in the 23 branch - because it was introduced when course_add_cm_to_section was refactored (MDL-35339).

          damyon Damyon Wiese added a comment -

          Thanks Jonathon,

          I tested this in integration and it works well.

          Integrated to 24 and master branches.

          I found the bug that caused this regression and confirmed it does not occur in 23.

          damyon Damyon Wiese added a comment -

          Tested on 24 and master branches in integration. Works as described.

          poltawski Dan Poltawski added a comment -

          Thanks! You're changes are now spread to the world through this git and our source control repositories.

          No time to rest though, we've got days to make 2.5 the best yet!

          ciao


            People

            • Votes:
              4 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                13/May/13