Moodle
  1. Moodle
  2. MDL-38061

idnumber field does not display in the assignment module

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.4, 2.4.1
    • Fix Version/s: 2.3.5, 2.4.2
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      1. Needs testing on all branches
      2. Create an assignment with offline marking enabled
      3. Change the admin setting "showuseridentity" to include all custom fields
      4. Go to the grading page for the assignment
      5. Confirm that it has columns for each extra user field and the table can be sorted by each
      6. Download grades as csv
      7. Verify the csv contains the extra user fields
      8. Go to the grade page for a single student
      9. Verify the summary contains the extra user fields after the student name
      10. Create a new assignment with blind marking and offline marking enabled
      11. Go to the grading page for the assignment
      12. Verify you do not see the extra columns for the user fields
      13. Download grades as csv
      14. Verify the csv does not contain the extra user fields
      15. Go to the grade page for a single student
      16. Verify the summary does not contain the extra user fields after the participant id
      Show
      Needs testing on all branches Create an assignment with offline marking enabled Change the admin setting "showuseridentity" to include all custom fields Go to the grading page for the assignment Confirm that it has columns for each extra user field and the table can be sorted by each Download grades as csv Verify the csv contains the extra user fields Go to the grade page for a single student Verify the summary contains the extra user fields after the student name Create a new assignment with blind marking and offline marking enabled Go to the grading page for the assignment Verify you do not see the extra columns for the user fields Download grades as csv Verify the csv does not contain the extra user fields Go to the grade page for a single student Verify the summary does not contain the extra user fields after the participant id
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Pull from Repository:
    • Pull 2.4 Branch:
    • Pull Master Branch:
      MDL-38061-master
    • Rank:
      47858

      Description

      Despite Sam Marshall's efforts in MDL-26647, the assignment module still does not display idnumbers. This is essential in many educational contexts where there are students with identical names, particularly in Eastern Asia or schools with a large population of students from Asian countries.

        Issue Links

          Activity

          Michael de Raadt added a comment -

          Thanks for reporting that, Thom.

          It looks like those changes were made to the assignment module (pre-2.2) but not the new assign module (2.2 onwards). I confirmed this in the interface.

          Damyon Wiese added a comment -

          Re: backport - I think this is a bug rather than an improvement because this change was implemented for other modules in 2.2 - so the setting exists but is not used by assignment (until now).

          Damyon Wiese added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          Thanks!

          Dan Poltawski added a comment -

          Integrated to master, 24 and 23 - thanks Damyon

          Jason Fowler added a comment -

          All Good Damyon!

          Eloy Lafuente (stronk7) added a comment -

          Because

          A
          MARVELOUS
          A       U
          Z  YOU  P
          I  ARE  E
          N  PPL  R
          G       B
            TNKS! 
          

          Closing, ciao


            People

            • Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: