Moodle
  1. Moodle
  2. MDL-38075

Coding error: trying to call a method on a non-object

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.4, 2.4.1, 2.5
    • Fix Version/s: 2.3.5, 2.4.2
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      1. Enable the CSS optimiser.
      2. Install the bootstrap theme from the plugins database.
      3. Change to the bootstrap theme.
      4. Observe that the CSS is generated without an error. (view the CSS file in your browser and check there isn't an error at the top).
      Show
      Enable the CSS optimiser. Install the bootstrap theme from the plugins database. Change to the bootstrap theme. Observe that the CSS is generated without an error. (view the CSS file in your browser and check there isn't an error at the top).
    • Workaround:

      Disable the CSS optimiser.

      Show
      Disable the CSS optimiser.
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Pull Master Branch:
      wip-MDL-38075-m25

      Description

      There is a coding error within csslib line 1751.

        Gliffy Diagrams

          Activity

          Sam Hemelryk added a comment -

          Up for peer-review now.

          Sam Hemelryk added a comment -

          Actually I'm confident with this change and I would like this included in this weeks integration.

          Mary Evans added a comment - - edited

          Just peer reviewing this for you Sam.

          In the main it looks like it's working ok until you try fully responsive page views.
          To do this just float the window (restore down) and then make the screen about 250px wide.
          See attached images.

          The problem is the @media css gets all screwed up.

          Sorry but it's not working as we would like it.

          Mary

          Mary Evans added a comment - - edited

          In the images you can see the page set out as you would see it in a mobile device.

          1. First image shows the menu closed with the highlighted button closed.
          2. Second image shows the menu open with the main page beneath with side blocks above center page.
          3. Third image shows the Optimised CSS view where the page loses all styling.

          Mary Evans added a comment -

          Sam, I've just tested my Tiny Bootstrap theme and it works OK!!!
          There must be something wrong with the layout in Bas Brands version then.

          How very odd.

          Eloy Lafuente (stronk7) added a comment -

          Integrated (23, 24 & master), thanks!

          David Monllaó added a comment -

          Passing it, no coding error detected when using CSS optimizer. What I've noticed is that with CSS optimizer enabled and bootstrap theme selected the main region goes below the pre region instead of at it's side

          Damyon Wiese added a comment -

          Thanks for your hard work - this issue has made it! Moodle is now a little bit better.

          Regards, Damyon


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: