Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-38076

New 2.4 icons too large for "Edit Quiz/Order and Paging" page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4.1, 2.5
    • Fix Version/s: 2.4.2
    • Component/s: Quiz, Themes
    • Labels:
    • Testing Instructions:
      1. Create a new quiz and add a 4 questions
      2. On the 'Edit quiz' page, make sure the icons 'up', 'down', 'delete' are visible for the different questions and the look and feel is good
      3. Switch to an RTL language and repeat step 2.
      Show
      Create a new quiz and add a 4 questions On the 'Edit quiz' page, make sure the icons 'up', 'down', 'delete' are visible for the different questions and the look and feel is good Switch to an RTL language and repeat step 2.
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-38076-master

      Description

      Since the release of the new icon set in 2.4, in at least one place, some of the icons are too large to be displayed properly. The one (and only, so far) page where this is a problem is "Edit Quiz/Order and Paging" – namely the arrow and delete (X) icons. The old, smaller (pre- 2.4) icons displayed fine, but the 2.4 icons appear to be too large for the space allotted to them in the existing stock themes. This issue is evident in the themes I've checked (e.g., stock Formal White theme). I think the stock themes may need to be updated to address this.

        Gliffy Diagrams

          Issue Links

            Activity

            timhunt Tim Hunt added a comment -

            Adding Fred and Barbara as watchers, since they did the new icons in 2.4.

            fred Frédéric Massart added a comment -

            Hi Tim,

            as I was debugging it to see where the problem came I created a patch and assigned the issue to myself.

            The problem is not the size of the icons which are meant to be 12x12 for "action" icons in most places, but we failed to notice that some width needed to be changed. That's what the patch does.

            I've assigned yourself as peer reviewer.

            Cheers,
            Fred

            rjerz Rick Jerz added a comment -

            I am a little puzzled. I am running Moodle 2.4+ (Build: 20121230), Formal White, and I do not see these icons. I wonder why? I do have the textboxes, where I can renumber the questions.

            Also, in your example, I detect that you are running "Chrome". The width of the textboxes, in Chrome, are not wide enough to see 3-digit numbers, such as 100. I wonder why? In Firefox you see the entire 3-digit number. Is this a "Chrome" feature?

            timhunt Tim Hunt added a comment -

            Rick, can you attach a screen-grab?

            Fred, thanks for taking this on. Patch looks OK to me.

            damyon Damyon Wiese added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            Thanks!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            oh my, wtf line is that, 405 char len! Cannot we move to simpler "border-radius" forall and forget about browser ones? Also, surely... if you want to support all them, it's missing some -moz-xxxx one, isn't it?

            http://caniuse.com/border-radius

            Ciao

            fred Frédéric Massart added a comment -

            Surely, but "I" don't want to support them, I've just changed the width.
            Should this issue take care of cleaning this CSS?

            timhunt Tim Hunt added a comment -

            I agree with Fred. File a new bug assigned to me to clean up the historic mess (Which has not been changed for years.)

            This issue should just focus on the bug fix.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Yes, agree. Just highlighting it.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            MDL-38209 has been created about the cleanup.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated (24 & master), thanks!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Tested while reviewing, FF/Safari/Chrome/IE8, english and hebrew. Buttons are shown properly under all them.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Because

            A
            MARVELOUS
            A       U
            Z  YOU  P
            I  ARE  E
            N  PPL  R
            G       B
              TNKS! 
            

            Closing, ciao

            bnwinsf Brian Warling added a comment -

            I just installed Moodle 2.4.2 (Build: 20130311). The arrow and delete icons on the quiz editing (order and paging) page are now gone. I've attached a screenshot. Does anyone else see this? Thanks... Brian

            bnwinsf Brian Warling added a comment -

            Quick update on my previous comment. We're seeing this issue on existing quizzes. When we create a new quiz (on 2.4.2 - Build 20130311), the arrow and delete icons are present. Thanks... Brian

            fred Frédéric Massart added a comment -

            Hi Brian, that's a bit strange as a bug. Could please try to flush your cache and switch to the standard theme? Perhaps your custom theme has troubles with the new width and the floating. Thanks!

            fred Frédéric Massart added a comment -

            (I just noticed that I missed to update some margin on the "Order and paging" tab, but you should still be able to see it.)

            bnwinsf Brian Warling added a comment - - edited

            I just figured out what the problem was. User error (mine). I was looking at the quiz edit page for a quiz that had attempts (I wasn't expected any attempts since no one is really using this server). Of course it's not going to let me modify the quiz. My apologies. (and thanks for addressing this icon problem to begin with.) – Brian (P.S. And purging the server cache was important, too).

            timhunt Tim Hunt added a comment -

            OK. Thanks for letting us know.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Mar/13