Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-38329

TinyMCE needs lists plugin to fix a Webkit lists bug

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.7, 2.3.3, 2.3.4, 2.4, 2.4.1, 2.5
    • Fix Version/s: 2.3.7, 2.4.4
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None

      Description

      See https://moodle.org/mod/forum/discuss.php?d=223251#p972356

      Chrome and Safari add extra span tags to lists in editor.

      The easy fix is to replace word "safari" with word "lists" in init code of TinyMCE (safari-plugin was removed from core tinymce 3 years ago)

      Lists-plugin was added to tinymce version 3.4.1 and further improved in tinymce version 3.5.5 so this one-word-fix can be done for all the supported stable versions of moodle 2.X

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              korpelainen Mauno Korpelainen added a comment -

              Petr,

              note also that core tinymce lists-plugin does not need any buttons so it goes only to

              'plugins' =>

              skodak Petr Skoda added a comment -

              Thanks for the report.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated (23, 24 & master), thanks!

              ankit_frenz Ankit Agarwal added a comment - - edited

              I couldn't replicate it on stable master using chrome, so am not sure if am testing the correct thing. Testing instructions are not specific, and I didnot see any span tags so passing.
              Thanks

              damyon Damyon Wiese added a comment -

              This issue has been integrated upstream and is now available via git (and in some hours, via mirrors and downloads).

              Thanks for your contributions!

              rex Rex Lorenzo added a comment - - edited

              I created a bug at MDL-39344, because MOODLE_23_STABLE now has a regression due to this ticket. List items now unindent when you hit backspace/delete instead of just deleting the character in the string you are editing.

              Apparently this is fixed in TinyMCE 3.5.5, which Moodle 2.4+ run, but not for 3.5.1, which Moodle 2.3 runs.

              Patch should probably be reverted for the MOODLE_23_STABLE branch.

              skodak Petr Skoda added a comment -

              Thanks, I have submitted pull request for the commit revert in 2.3x.


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    13/May/13