Moodle
  1. Moodle
  2. MDL-3834

rss_client block does not honour HTTP proxy setting

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.5.2
    • Fix Version/s: None
    • Component/s: RSS
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_15_STABLE
    • Rank:
      14484

      Description

      The rss_client block does not honour the HTTP proxy setting in Moodle's main configuration. This means that Moodle will fail to fetch RSS feeds when it is installed at a site where it is mandatory to use a HTTP proxy.

        Activity

        Hide
        Martin Dougiamas added a comment -

        From Michael Schneider (moodle at oncode.info) Sunday, 7 August 2005, 02:54 AM:

        This is a patch which should resolve this prob....

        Affected files:

        1.18 - lib/rsslib.php

        1.2 - lib/magpie/rss_fetch.inc

        It worx on our site,,,,

        From (mwest at uct.ac.za) Sunday, 7 August 2005, 05:21 AM:

        The patch works for me. Thanks!

        From Daryl Hawes (dhawes at mac.com) Wednesday, 22 March 2006, 04:56 AM:

        Contents of the enclosed patch have been applied to HEAD. I'll allow some time for verification from folks with proxy config before closing this bug.

        From Martin Dougiamas (martin at moodle.com) Monday, 3 April 2006, 09:49 AM:

        This part is unnecessary:

        if(isset($CFG->proxyhost) && $CFG->proxyhost) {

        and actually causes problems in 1.6 Beta when proxies are not in use. I've removed them in my local copy and will check it in as soon as CVS comes back from the dead.

        Show
        Martin Dougiamas added a comment - From Michael Schneider (moodle at oncode.info) Sunday, 7 August 2005, 02:54 AM: This is a patch which should resolve this prob.... Affected files: 1.18 - lib/rsslib.php 1.2 - lib/magpie/rss_fetch.inc It worx on our site,,,, From (mwest at uct.ac.za) Sunday, 7 August 2005, 05:21 AM: The patch works for me. Thanks! From Daryl Hawes (dhawes at mac.com) Wednesday, 22 March 2006, 04:56 AM: Contents of the enclosed patch have been applied to HEAD. I'll allow some time for verification from folks with proxy config before closing this bug. From Martin Dougiamas (martin at moodle.com) Monday, 3 April 2006, 09:49 AM: This part is unnecessary: if(isset($CFG->proxyhost) && $CFG->proxyhost) { and actually causes problems in 1.6 Beta when proxies are not in use. I've removed them in my local copy and will check it in as soon as CVS comes back from the dead.
        Hide
        Dan Marsden added a comment -

        this aint closed properly - reopening so I can close it properly with a resolution.

        Dan

        Show
        Dan Marsden added a comment - this aint closed properly - reopening so I can close it properly with a resolution. Dan

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: