Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-38345

Error reading from database in http://qa.moodle.net/my/

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.4.2
    • Component/s: Course
    • Labels:
      None
    • Testing Instructions:
      • With the patch applied....
      • Go to /my (verify it works).
      • Edit the database and delete the 'navsortmycoursessort' record from the config table (and purge caches, esp under master!).
      • Reload the /my page (it continues working - was throwing BD error before the patch).

      That's all!

      Show
      With the patch applied.... Go to /my (verify it works). Edit the database and delete the 'navsortmycoursessort' record from the config table (and purge caches, esp under master!). Reload the /my page (it continues working - was throwing BD error before the patch). That's all!
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      In My Courses page, there are some database issues. There might be some undefined property

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              poltawski Dan Poltawski added a comment -

              This caused by $CFG->navsortmycoursessort not being set after upgrade. Introduced by MDL-32975.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              But I'm sure we did version bump with MDL-32975, precisely to avoid that. How can it be possible?

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Anyway, if it's happening... better quick patch to be 100% in the safe side... looking for it right now.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Sending it straight to integration, simple enough.

              poltawski Dan Poltawski added a comment -

              Integrated, thanks Eloy

              poltawski Dan Poltawski added a comment -

              and passed

              stronk7 Eloy Lafuente (stronk7) added a comment -

              This is valid for unlimited entries to the, soon to be unveiled, Moodle Codebase Gardens. It includes free access to all facilities.

              Personal and non-transferable to all assignees, reviewers and testers in this issue. Valid until switching to Blackboard (100000€ penalization will be applied).

              Thanks, closing as fixed!

              itsmerht Rohith eAbyas added a comment -

              Thank you..


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Mar/13