Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-38376

Feedback displayed when Grade set to hidden

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4.4, 2.5
    • Fix Version/s: 2.4.5, 2.5.1
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:

      1. Create an assignment with feedback comments enabled
      2. Hide the gradebook column for the assignment
      3. Grade a student and provide a grade + feedback comment
      4. View the assignment as a student and verify you cannot see the feedback or the grade.
      5. Unhide the gradebook column for the assignment.
      6. View the assignment as a student and verify you can see the feedback and the grade.

      Show
      1. Create an assignment with feedback comments enabled 2. Hide the gradebook column for the assignment 3. Grade a student and provide a grade + feedback comment 4. View the assignment as a student and verify you cannot see the feedback or the grade. 5. Unhide the gradebook column for the assignment. 6. View the assignment as a student and verify you can see the feedback and the grade.
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Pull Master Branch:
      MDL-38376-master-feedback-displayed

      Description

      We are running the latest Moodle 2.4.1+ (Build: 20130307)

      When we hide assignment grades (hidden in Grade item) it now only hides the grade and not the Feedback or Feedback files from Students. We have tested and this is only happening on our 2.4.1 Moodles and not our Moodles still on 2.4

      Thanks

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              ldavies Louise Davies added a comment -

              Hi, hope it's ok- I have changed the priority to major on this one as we are pretty desperate as our assignment submission process for 600+ distance learning students has effectively broken down since we upgraded to 2.4.1.
              I checked the release notes for 2.4.2 and there is no mention of anything solving this issue. BTW, sorry if I am not following the correct process, I am new to the tracker...
              Cheers,
              Louise

              damyon Damyon Wiese added a comment -

              The change that introduced this inadvertently was MDL-37635. (This change even added unit tests to verify that you could give feedback without releasing the grade).

              This should revert to the old behaviour and a new feature should be added to give more control over the release of grades/feedback.

              ldavies Louise Davies added a comment -

              Many thanks

              ldavies Louise Davies added a comment -

              Just wondering when this might be fixed as we are on 2.4 but finding that there are more problems with assignments due to bugs that have been fixed in later versions (e.g. https://tracker.moodle.org/browse/MDL-34592). But we cant upgrade to later versions because of this bug so we are stuck between a rock and a hard place!
              I know its hard to say but if its going to be weeks we can wait but if its not going to be fixed for some time we will have to upgrade and work out a new process. Any ideas?
              Many thanks, Louise

              ldavies Louise Davies added a comment -

              This is still an issue in 2.5, do I need to re-report it on the tracker as effecting this version too?

              damyon Damyon Wiese added a comment -

              This issue was assigned to me automatically, however I will not be able to work on this issue in the immediate future. In order to create a truer sense of the state of this issue and to allow other developers to have chance to become involved, I am removing myself as the assignee of this issue.

              For more information, see http://docs.moodle.org/dev/Changes_to_issue_assignment

              robwoof Rob Woof added a comment - - edited

              I can confirm that it is still an issue in 2.5 (20130514). Also in 2.4.4 (20130513). I have not been able to test in other versions.

              amanda.doughty Amanda Doughty added a comment -

              Providing a fix for the bug in 2.4.4 as we do need this urgently. Can the new feature suggested by Damyon, be added as a new issue/sub task?

              tsala Helen Foster added a comment -

              Amanda, thanks for your patch. I'm adding a 'patch' label, to hopefully help ensure that it is reviewed sooner rather than later.

              robwoof Rob Woof added a comment -

              Tested in 2.4.4 and verified OK. Feedback Comment and Feedback File were invisible to student when the "Hidden" was selected in Gradebook. Also verified that the "Hidden until" setting works as well.

              robwoof Rob Woof added a comment -

              I should also add: thanks, Amanda! It looks to me like you have nailed it (as far as I can tell). Very much appreciated!

              Let's hope some others can test as well to double- and triple-check it.

              robwoof Rob Woof added a comment -

              Tested in 2.5, and it breaks the display of feedback to students. That is, regardless of the setting in the Gradebook, the student sees no feedback. When I reverted to the "stable" code, the student sees feedback regardless of the Gradebook setting.

              So, from my testing, it works in 2.4.4, but breaks 2.5.

              amanda.doughty Amanda Doughty added a comment -

              Thanks for testing Rob. My fix is just for 2.4.4. 2.5 was added to the 'Affected versions' after I posted. We are not intending to run 2.5 until next year, but I will download the code and see if I can provide a fix for 2.5 also.

              andyjdavis Andrew Davis added a comment -

              The code change looks reasonable.

              Damyon mentioned unit tests above "This change even added unit tests to verify that you could give feedback without releasing the grade" If the unit tests were not detecting this problem it sounds like there's something wrong with the unit tests that needs fixing. It would be nice to have a unit test that fails before this fix but passes after it to ensure this bug doesn't creep back in later.

              Otherwise this looks fine.

              ldavies Louise Davies added a comment -

              Just tested on our Moodle 2.4.3. All seems to work ok. Tested 'hidden until' too. Many thanks for fixing.

              robwoof Rob Woof added a comment - - edited

              Amanda, you are a gem! I gave it a run in 2.5 just out of curiosity, but now you have done a 2.5 version as well. Many thanks! I will run some tests of the 2.5 version now and see how it goes.

              robwoof Rob Woof added a comment -

              Tested the 2.5 version on 2.5, and it works. Tested with "Hidden Until" as well as just plain "Hidden", and it's all good.

              Three cheers for Amanda!

              amanda.doughty Amanda Doughty added a comment -

              The unit tests are only in master (2.6DEV). They currently test:

              1. No grade or feedback given = no feedback table shown
              2. Grade given = feedback table shown
              3. Grade given but hidden = no feedback table shown
              4. Only feedback given = feedback table shown without grade and graded on rows

              So they will pass with or without the fix.

              The missing test is:
              5. Grade and feedback given but hidden = no feedback table shown

              I will update the github fixes to include master, with the additional test

              I will also edit the fixes for 2.4 and 2.5 as they fail test 4

              andyjdavis Andrew Davis added a comment -

              Looks like we're all set. Just expand the testing instructions a little to include when the grade isn't hidden ie check that the student can in fact see feedback when they're meant to be able to. Submit for integration whenever you're ready

              amanda.doughty Amanda Doughty added a comment -

              Hi Andy. I have added the additional testing instructions. I do not have authority to submit it for integration. Could you submit it please?

              andyjdavis Andrew Davis added a comment -

              Submitting for integration

              poltawski Dan Poltawski added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              amanda.doughty Amanda Doughty added a comment -

              Rebased. I hope! I'm really falling out with git

              samhemelryk Sam Hemelryk added a comment -

              Thanks Amanda, this has been integrated now

              As a heads up I had to clean up your branches when I merged them.
              Something very weird had gone on with them, sounds like you may have had a bit of trouble with git there. Feel free to ask questions if you need to.

              Many thanks
              Sam

              amanda.doughty Amanda Doughty added a comment -

              Thanks Sam. I use svn daily and I can just about manage the basics in git, but then I get challenged with squishing and rebasing and it all falls apart! I thought I had nailed it this time. We are moving to git this summer, so I will get there eventually.

              samhemelryk Sam Hemelryk added a comment -

              No probs at all. Best of luck with the move to git!

              rwijaya Rossiani Wijaya added a comment -

              This is working as expected.

              Tested for 2.4, 2.5 and master.

              Test passed.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Thanks for giving me joys and smiles
              Thanks for sharing my trouble's pile

              Thanks for wipeing the tears of my eye
              Thanks for showing me the glad view of sky

              Thanks for lending me your shoulders to lean
              Thanks for giving my words a proper mean

              Thanks for telling me the value of life
              Thanks for showing me the rules to survive

              Thanks for lending me the sympathetic ears
              Thanks for showing how much you care

              From all this what I mean in the end
              Is thanks for being my special friend.

              – Seema Chowdhury

              Sent upstream so... closing, thanks!


                People

                • Votes:
                  9 Vote for this issue
                  Watchers:
                  12 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    8/Jul/13