Moodle
  1. Moodle
  2. MDL-38395

After editing question category a question editing links points to this category

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.6, 2.4.1, 2.5
    • Fix Version/s: 2.3.7, 2.4.4
    • Component/s: Questions
    • Labels:
    • Testing Instructions:
      Hide

      1. Go to the 'Categories' page of the question bank.

      2. Add a new category.

      3. Edit that new category, and save changes.

      4. Now check that the links to the questions in each category (the numbers in brackets) actually go to the right category.

      5. Check that the delete icons work.

      Show
      1. Go to the 'Categories' page of the question bank. 2. Add a new category. 3. Edit that new category, and save changes. 4. Now check that the links to the questions in each category (the numbers in brackets) actually go to the right category. 5. Check that the delete icons work.
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Pull from Repository:
    • Pull 2.4 Branch:
    • Pull Master Branch:
    • Rank:
      48319

      Description

      Reproduced on qa.moodle.net

      Steps:
      1. Get a course with some questions in category (like "Questions and more questions" on qa.moodle.net)
      2. Create an empty second category at a top
      3. Go to category editing screen for second category (click on its name) and move it to be a child of first category
      4. Save it and you will be returned to the categories page. Now look on question editing links (on the number of questions in the brackets after category name). They all point to the edited category, which they obviously shoudn't.

        Issue Links

          Activity

          Hide
          Tim Hunt added a comment -

          This was a bug with array1 + array2 being the wrong way around (so it used the value from array1, not array 2).

          Show
          Tim Hunt added a comment - This was a bug with array1 + array2 being the wrong way around (so it used the value from array1, not array 2).
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Uhm, it sounds to me I reported this loooong ago.

          Show
          Eloy Lafuente (stronk7) added a comment - Uhm, it sounds to me I reported this loooong ago.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Integrated (23, 24 & master), thanks!

          Show
          Eloy Lafuente (stronk7) added a comment - Integrated (23, 24 & master), thanks!
          Hide
          Rajesh Taneja added a comment -

          Thanks Tim,

          After editing newly created category, links point to correct url.

          FYI:
          In stable and integration: If you create new category under default category (for course), delete icon is visible for default category and clicking them gives following error:

          You can't delete that category it is the default category for this context.
          

          Also, if there are any questions in default for category, then you see option to move questions and then see above error. Probably another issue.

          Show
          Rajesh Taneja added a comment - Thanks Tim, After editing newly created category, links point to correct url. FYI: In stable and integration: If you create new category under default category (for course), delete icon is visible for default category and clicking them gives following error: You can't delete that category it is the default category for this context. Also, if there are any questions in default for category, then you see option to move questions and then see above error. Probably another issue.
          Hide
          Tim Hunt added a comment -

          Thanks Raj. Yes, that is a separate issue.

          Show
          Tim Hunt added a comment - Thanks Raj. Yes, that is a separate issue.
          Hide
          Damyon Wiese added a comment -

          This issue has been integrated upstream and is now available via git (and in some hours, via mirrors and downloads).

          Thanks for your contributions!

          Show
          Damyon Wiese added a comment - This issue has been integrated upstream and is now available via git (and in some hours, via mirrors and downloads). Thanks for your contributions!

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: