Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-38397

Error message when saving embedded answers (cloze) type quiz question

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.6, 2.4.1, 2.5
    • Fix Version/s: 2.3.7, 2.4.4
    • Component/s: Questions
    • Labels:
      None

      Description

      We've got the latest update of Moodle (Moodle 2.4.1+ (Build: 20130308)) and we are now experiencing trouble saving cloze type quiz questions. I had no trouble a few weeks ago with Moodle 2.4.1 (I'm not sure which build).

      To get the error:
      1a. create a new quiz question of "Embedded Answers (Cloze)" type.
      1b. click edit to an existing "Embedded Answers (Cloze)" question
      2. Make/edit the question
      3. Click "save changes"
      4. Get error screen that says: "Notice: Undefined index: defaultmark in /Library/WebServer/Documents/moodle/question/type/edit_question_form.php on line 659
      Skip to main content
      "

      I'm not having trouble with other question types such as multiple choice (I haven't tried them all).

      Apologies if this has been reported already. I searched the tracker and didn't see anything like this.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              timhunt Tim Hunt
              Reporter:
              andy@fun Andrew Johnson
              Integrator:
              Eloy Lafuente (stronk7)
              Tester:
              Andrew Davis
              Participants:
              Component watchers:
              Tim Hunt, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                13/May/13