Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Administration
    • Labels:

      Description

      On the settings pages during upgrade and then on my site's home page I'm getting the following displayed.

      Sibling File download not found

      line 996 of /lib/adminlib.php: call to debugging()
      line 216 of /admin/settings/plugins.php: call to admin_category->add()
      line 6355 of /lib/adminlib.php: call to require()
      line 6242 of /lib/adminlib.php: call to admin_get_root()
      line 14 of /admin/upgradesettings.php: call to admin_externalpage_setup()

      Sibling File download not found

      line 996 of /lib/adminlib.php: call to debugging()
      line 216 of /admin/settings/plugins.php: call to admin_category->add()
      line 6355 of /lib/adminlib.php: call to require()
      line 17 of /admin/upgradesettings.php: call to admin_get_root()

      Sibling File download not found

      line 996 of /lib/adminlib.php: call to debugging()
      line 216 of /admin/settings/plugins.php: call to admin_category->add()
      line 6355 of /lib/adminlib.php: call to require()
      line 6454 of /lib/adminlib.php: call to admin_get_root()
      line 21 of /admin/upgradesettings.php: call to admin_write_settings()

      Sibling File download not found

      line 996 of /lib/adminlib.php: call to debugging()
      line 216 of /admin/settings/plugins.php: call to admin_category->add()
      line 6355 of /lib/adminlib.php: call to require()
      line 22 of /admin/upgradesettings.php: call to admin_get_root()

        Gliffy Diagrams

          Issue Links

            Activity

            fred Frédéric Massart added a comment -

            Very similar problem:

            Sibling Box.net not found
            line 996 of /lib/adminlib.php: call to debugging()
            line 216 of /admin/settings/plugins.php: call to admin_category->add()
            line 6355 of /lib/adminlib.php: call to require()
            line 3248 of /lib/navigationlib.php: call to admin_get_root()
            line 3153 of /lib/navigationlib.php: call to settings_navigation->load_administration_settings()
            line 701 of /lib/pagelib.php: call to settings_navigation->initialise()
            line 717 of /lib/pagelib.php: call to moodle_page->magic_get_settingsnav()
            line 71 of /course/renderer.php: call to moodle_page->__get()
            line 52 of /course/renderer.php: call to core_course_renderer->add_modchoosertoggle()
            line 240 of /lib/outputfactories.php: call to core_course_renderer->__construct()
            line 1298 of /lib/outputlib.php: call to standard_renderer_factory->get_renderer()
            line 754 of /lib/pagelib.php: call to theme_config->get_renderer()
            line 52 of /course/format/renderer.php: call to moodle_page->get_renderer()
            line 240 of /lib/outputfactories.php: call to format_section_renderer_base->__construct()
            line 1298 of /lib/outputlib.php: call to standard_renderer_factory->get_renderer()
            line 754 of /lib/pagelib.php: call to theme_config->get_renderer()
            line 135 of /course/view.php: call to moodle_page->get_renderer()
            Sibling Google Docs not found
            line 996 of /lib/adminlib.php: call to debugging()
            line 216 of /admin/settings/plugins.php: call to admin_category->add()
            line 6355 of /lib/adminlib.php: call to require()
            line 3248 of /lib/navigationlib.php: call to admin_get_root()
            line 3153 of /lib/navigationlib.php: call to settings_navigation->load_administration_settings()
            line 701 of /lib/pagelib.php: call to settings_navigation->initialise()
            line 717 of /lib/pagelib.php: call to moodle_page->magic_get_settingsnav()
            line 71 of /course/renderer.php: call to moodle_page->__get()
            line 52 of /course/renderer.php: call to core_course_renderer->add_modchoosertoggle()
            line 240 of /lib/outputfactories.php: call to core_course_renderer->__construct()
            line 1298 of /lib/outputlib.php: call to standard_renderer_factory->get_renderer()
            line 754 of /lib/pagelib.php: call to theme_config->get_renderer()
            line 52 of /course/format/renderer.php: call to moodle_page->get_renderer()
            line 240 of /lib/outputfactories.php: call to format_section_renderer_base->__construct()
            line 1298 of /lib/outputlib.php: call to standard_renderer_factory->get_renderer()
            line 754 of /lib/pagelib.php: call to theme_config->get_renderer()
            line 135 of /course/view.php: call to moodle_page->get_renderer()

            mudrd8mz David Mudrak added a comment -

            Andrew, are you sure this was spotted at Moodle 2.4 as filled? It is clearly caused by the linked MDL-38497 but that was integrated into master only.

            mudrd8mz David Mudrak added a comment -

            Confirmed. This is not a bad regression. It's just that MDL-38497 reveals places where $ADMIN->add() has been called with extra parameters. E.g. Fred's report is caused by:

            $ADMIN->add(
                'portfoliosettings',
                new admin_externalpage(
                    'portfoliosettings' . $portfolio->get('id'),
                    $portfolio->get('name'),
                    $url . '?action=edit&pf=' . $portfolio->get('id'),
                    'moodle/site:config'
                ),
                $portfolio->get('name'),
                $url . '?action=edit&pf=' . $portfolio->get('id')
            );

            and as you can see, the third and the fourth parameter for add() should not be there. This seems to be pretty common in portfolio/repository code, I'll have to check if that was some relict of copy/paste from somewhere else or of they actually were supposed to do something.

            andyjdavis Andrew Davis added a comment -

            Updated the affects version.

            fred Frédéric Massart added a comment -

            Requesting peer review. Looking at the lines above, it seems that we had wrongly set the parameters, and didn't remove them once fixed. I grepped the code to find similar issues but didn't spot anything.

            mudrd8mz David Mudrak added a comment -

            Mike Delta Lima Tree Ait Fife Six Tree, you are cleared to land. Thanks Fred!

            fred Frédéric Massart added a comment -

            \o/ Thanks!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks!

            ankit_frenz Ankit Agarwal added a comment -

            Reported MDL-38738 for settype issues.

            Passing this test.
            Thanks

            damyon Damyon Wiese added a comment -

            Thanks for your hard work. This issue has been integrated upstream and is now available via git (and in some hours, via mirrors and downloads).


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/May/13