Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-38634

Problems displaying multiple folder resources inline in the course page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Resource
    • Labels:
    • Testing Instructions:

      Create Folder resources A & B with sub folders with content.

      Case 1:

      • Set both folders settings:
        • "Display foder contents: Inline on a course page"
        • "Show sub-folders expanded: checked"
      • Go to course page and verify that both folder resources display with all their sub-folders expanded

      Case 2:

      • Set folder A settings:
        • "Display foder contents: Inline on a course page"
        • "Show sub-folders expanded: checked"
      • Set folder B settings:
        • "Display foder contents: Inline on a course page"
        • "Show sub-folders expanded: unchecked"
      • Go to course page and verify that folder A resources display with all their sub-folders expanded. Verify that folder B resources display with their sub-folders collapsed.

      Case 3:

      • Set both folders settings:
        • "Display foder contents: Inline on a course page"
        • "Show sub-folders expanded: unchecked"
      • Go to course page and verify that both folder resources display with their sub-folders collapsed.
      Show
      Create Folder resources A & B with sub folders with content. Case 1: Set both folders settings: "Display foder contents: Inline on a course page" "Show sub-folders expanded: checked" Go to course page and verify that both folder resources display with all their sub-folders expanded Case 2: Set folder A settings: "Display foder contents: Inline on a course page" "Show sub-folders expanded: checked" Set folder B settings: "Display foder contents: Inline on a course page" "Show sub-folders expanded: unchecked" Go to course page and verify that folder A resources display with all their sub-folders expanded. Verify that folder B resources display with their sub-folders collapsed. Case 3: Set both folders settings: "Display foder contents: Inline on a course page" "Show sub-folders expanded: unchecked" Go to course page and verify that both folder resources display with their sub-folders collapsed.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      Hi,

      while playing with the folder resource, I've detected that, if multiple ones are configured to be shown inline... only the first one seems to work, and the rest, are somehow borked (no tree lines, expand/collapse not working...)

      See the attached screenshot.

      Ciao

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              marina Marina Glancy added a comment -

              Hi Eloy, I tested it when I working on MDL-37455 and tried again now - everything works for me. What theme and course format are you using?

              marina Marina Glancy added a comment -

              ok, I hit it. It is broken on integration master, but ok on master. It seem to conflict with the change MDL-30790

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Aha, I was not really sure of which one, MDL-37455 or MDL-30790 was the culprit), thanks!

              marina Marina Glancy added a comment -

              Also it makes other JS on page not working, for example sections drag and drop.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              yup, same here. confirmed coz i cannot D&D anymore in that course page.

              rex Rex Lorenzo added a comment -

              Patched problems with folder javascript.

              marina Marina Glancy added a comment -

              Looks good to me. Thanks Rex

              poltawski Dan Poltawski added a comment -

              Integrated to master - thanks Rex!

              phalacee Jason Fowler added a comment -

              All good Rex, thanks for this.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Your awesome contributions are now part of Moodle, your fav LMS out there.

              Closing this as fixed.

              Many thanks for all the hard work, ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    14/May/13