Details

    • Rank:
      48769

      Description

      Did you remember to call setType() for 'email'? Defaulting to PARAM_RAW cleaning.
      line 1266 of /lib/formslib.php: call to debugging()
      line 919 of /lib/formslib.php: call to moodleform->detectMissingSetType()
      line 302 of /user/edit.php: call to moodleform->display()

        Activity

        Hide
        Damyon Wiese added a comment -

        Thinking this through - I changed the type to PARAM_EMAIL. This calls the same validate_email function as the form was doing anyway - but it is obvious in the code and the user still gets an invalidemail error message when they enter rubbish.

        Integrated to master only.

        Show
        Damyon Wiese added a comment - Thinking this through - I changed the type to PARAM_EMAIL. This calls the same validate_email function as the form was doing anyway - but it is obvious in the code and the user still gets an invalidemail error message when they enter rubbish. Integrated to master only.
        Hide
        Rossiani Wijaya added a comment -

        This is working as expected.

        Test passed.

        Show
        Rossiani Wijaya added a comment - This is working as expected. Test passed.
        Hide
        Damyon Wiese added a comment -

        Thanks for your hard work. This issue has been integrated upstream and is now available via git (and in some hours, via mirrors and downloads).

        Show
        Damyon Wiese added a comment - Thanks for your hard work. This issue has been integrated upstream and is now available via git (and in some hours, via mirrors and downloads).

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: