Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Questions
    • Labels:
    • Testing Instructions:
      Hide

      1) Add/Edit an instance of the following question types:

      • Calculated
      • Calculated multichoice (multiple times)
      • Simple calculated
      • Embedded answers (Cloze)
      • True/false

      (this next part sucks, sorry)
      2) VERIFY: You should not see any errors apart from, the following, which are to be addressed in [MDL-38885]:

      (You may or may not see all of these)

      Did you remember to call setType() for 'unit'? Defaulting to PARAM_RAW cleaning.
      Did you remember to call setType() for 'calcdistribution'? Defaulting to PARAM_RAW cleaning.
      Did you remember to call setType() for 'datasetdef'? Defaulting to PARAM_RAW cleaning.
      Did you remember to call setType() for 'defoptions'? Defaulting to PARAM_RAW cleaning.
      Did you remember to call setType() for 'number'? Defaulting to PARAM_RAW cleaning.
      Did you remember to call setType() for 'itemid'? Defaulting to PARAM_RAW cleaning.
      Did you remember to call setType() for 'definition'? Defaulting to PARAM_RAW cleaning.
      Did you remember to call setType() for 'tolerance'? Defaulting to PARAM_RAW cleaning.
      Did you remember to call setType() for 'multiplier'? Defaulting to PARAM_RAW cleaning.

      Show
      1) Add/Edit an instance of the following question types: Calculated Calculated multichoice (multiple times) Simple calculated Embedded answers (Cloze) True/false (this next part sucks, sorry) 2) VERIFY: You should not see any errors apart from, the following, which are to be addressed in [MDL-38885] : (You may or may not see all of these) Did you remember to call setType() for 'unit'? Defaulting to PARAM_RAW cleaning. Did you remember to call setType() for 'calcdistribution'? Defaulting to PARAM_RAW cleaning. Did you remember to call setType() for 'datasetdef'? Defaulting to PARAM_RAW cleaning. Did you remember to call setType() for 'defoptions'? Defaulting to PARAM_RAW cleaning. Did you remember to call setType() for 'number'? Defaulting to PARAM_RAW cleaning. Did you remember to call setType() for 'itemid'? Defaulting to PARAM_RAW cleaning. Did you remember to call setType() for 'definition'? Defaulting to PARAM_RAW cleaning. Did you remember to call setType() for 'tolerance'? Defaulting to PARAM_RAW cleaning. Did you remember to call setType() for 'multiplier'? Defaulting to PARAM_RAW cleaning.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull Master Branch:
      MDL-38741-master

      Description

      I encountered the following errors on the forms for the following question types.

      • Calculated
      • Calculated multichoice (multiple times)
      • Simple calculated
      • Embedded answers (Cloze)
      • True/false

      This one appears at the top of the page...

      Did you remember to call setType() for 'penalty'? Defaulting to PARAM_RAW cleaning.
       
          line 1275 of \lib\formslib.php: call to debugging()
          line 281 of \lib\formslib.php: call to moodleform->detectMissingSetType()
          line 202 of \lib\formslib.php: call to moodleform->_process_submission()
          line 113 of \question\type\edit_question_form.php: call to moodleform->moodleform()
          line 217 of \question\type\questiontypebase.php: call to question_edit_form->__construct()
          line 200 of \question\question.php: call to question_type->create_editing_form()
      

      This one appears just before the start of the form...

      Did you remember to call setType() for 'penalty'? Defaulting to PARAM_RAW cleaning.
       
          line 1275 of \lib\formslib.php: call to debugging()
          line 919 of \lib\formslib.php: call to moodleform->detectMissingSetType()
          line 271 of \question\type\questiontypebase.php: call to moodleform->display()
          line 346 of \question\question.php: call to question_type->display_question_editing_page()
      

      The penalty form element is not editable (hard frozen?).

      This appears to be affecting the current master only.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/May/13