Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      Hide
      1. Select Bootstrap theme from Theme selector.
      2. Browse to a course and turn editing on.
      3. Select to add a new workshop module.
      4. On the edit form click Expand all and check all sections are shown.
      5. Click collapse all and check the sections are collapsed again.
      6. Repeat for the course edit sections form to be extra sure.
      Show
      Select Bootstrap theme from Theme selector. Browse to a course and turn editing on. Select to add a new workshop module. On the edit form click Expand all and check all sections are shown. Click collapse all and check the sections are collapsed again. Repeat for the course edit sections form to be extra sure.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull Master Branch:
      MDL-38874_master
    • Rank:
      48969

      Description

      When showing a settings page with advanced settings the advanced settings are always shown and never hidden. The show more link does not toggle the display of these fields.

        Issue Links

          Activity

          Hide
          Mary Evans added a comment -

          Adrian, I have just been looking at this and don't see any problem with the expand/collapse toggle in Admin settings pages.

          Show
          Mary Evans added a comment - Adrian, I have just been looking at this and don't see any problem with the expand/collapse toggle in Admin settings pages.
          Hide
          Jean-Michel Vedrine added a comment -

          Hello Mary,
          The problem is not in the expand/collapse toggle but with the show more/show less toggle and I can confirm the problem not only in admin but in fact in a lot of places (everywhere ?)
          There is already an other issue open about this problem and with a fix. I will try to

          • retrieve it
          • link it here
          • make a github branch with the fix
          Show
          Jean-Michel Vedrine added a comment - Hello Mary, The problem is not in the expand/collapse toggle but with the show more/show less toggle and I can confirm the problem not only in admin but in fact in a lot of places (everywhere ?) There is already an other issue open about this problem and with a fix. I will try to retrieve it link it here make a github branch with the fix
          Hide
          Jean-Michel Vedrine added a comment -

          Linking with a duplicate witch include a fix

          Show
          Jean-Michel Vedrine added a comment - Linking with a duplicate witch include a fix
          Hide
          Jean-Michel Vedrine added a comment -

          After re-reading MDL-38922, I really wonder if I should make a branch to fix just this issue adding just the 2 lines to fix it.
          In fact this problem is part of a more general one : add to bootstrap all the recent changes to CSS introduced recently.
          Is it the good way to go to fix each one of them separately like this ?

          Show
          Jean-Michel Vedrine added a comment - After re-reading MDL-38922 , I really wonder if I should make a branch to fix just this issue adding just the 2 lines to fix it. In fact this problem is part of a more general one : add to bootstrap all the recent changes to CSS introduced recently. Is it the good way to go to fix each one of them separately like this ?
          Hide
          Mary Evans added a comment -

          When I said expand/collapse, I was including all the toggles on those admins pages.

          I tested it on a course page using Edit settings, and ALL the toggles worked, individual ones as well as the the Expand ALL/ Collapse ALL toggle too.

          I was testing in Simple theme (which inherits from Bootstrap theme) that was added in current version of Moodle $release = '2.5beta+ (Build: 20130418)

          Show
          Mary Evans added a comment - When I said expand/collapse, I was including all the toggles on those admins pages. I tested it on a course page using Edit settings, and ALL the toggles worked, individual ones as well as the the Expand ALL/ Collapse ALL toggle too. I was testing in Simple theme (which inherits from Bootstrap theme) that was added in current version of Moodle $release = '2.5beta+ (Build: 20130418)
          Hide
          Mary Evans added a comment -

          @Jean-Michel, I can do this now I know what the fix is. I have just closed MDL-38922 as it was a duplicate issue.

          The fix needs to go into theme/bootstrap/less/moodle/form.less

          .jsenabled .mform .containsadvancedelements .advanced {display: none;}
          .mform .containsadvancedelements .advanced.show {display: block;}
          
          Show
          Mary Evans added a comment - @Jean-Michel, I can do this now I know what the fix is. I have just closed MDL-38922 as it was a duplicate issue. The fix needs to go into theme/bootstrap/less/moodle/form.less .jsenabled .mform .containsadvancedelements .advanced {display: none;} .mform .containsadvancedelements .advanced.show {display: block;}
          Hide
          Mary Evans added a comment -

          @Jean-Michel, could you add to the Test Instructions as I am not sure what is the best way to test this?

          Show
          Mary Evans added a comment - @Jean-Michel, could you add to the Test Instructions as I am not sure what is the best way to test this?
          Hide
          Sam Hemelryk added a comment -

          Thanks Mary, this has been integrated now.

          Just as a heads up something was way off in your commit in regards to the generated CSS file.
          There was also a couple of tabs introduced by your changes.
          As part of integration I fixed up those whitespace issues and regenerated the CSS using recess.

          Many thanks
          Sam

          Show
          Sam Hemelryk added a comment - Thanks Mary, this has been integrated now. Just as a heads up something was way off in your commit in regards to the generated CSS file. There was also a couple of tabs introduced by your changes. As part of integration I fixed up those whitespace issues and regenerated the CSS using recess. Many thanks Sam
          Hide
          Sam Hemelryk added a comment -

          Tested and passed

          Show
          Sam Hemelryk added a comment - Tested and passed
          Hide
          Mary Evans added a comment -

          That was probably to do with the fact I can only use WinLess. There was a problem when I compiled it. Thanks for fixing that.

          Show
          Mary Evans added a comment - That was probably to do with the fact I can only use WinLess. There was a problem when I compiled it. Thanks for fixing that.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          I feel myself really alone tonight! So was time to push your fixes upstream!

          "Lest we forget. We will remember them."

          Thanks and ciao!

          Show
          Eloy Lafuente (stronk7) added a comment - I feel myself really alone tonight! So was time to push your fixes upstream! "Lest we forget. We will remember them." Thanks and ciao!

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: