Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Course
    • Labels:
    • Testing Instructions:

      NOTE: Make sure there is no label or file resource present in the course which you will use in this test.

      1. Login as teacher, go to the course page then turn editing on.
      2. Create a label by dragging an image onto the course page
      3. Attempt to delete a label.
      4. Check that the popup asks to confirm deletion 'Are you sure you want to delete this Label?'
      5. Test above with file resource.
      Show
      NOTE: Make sure there is no label or file resource present in the course which you will use in this test. Login as teacher, go to the course page then turn editing on. Create a label by dragging an image onto the course page Attempt to delete a label. Check that the popup asks to confirm deletion 'Are you sure you want to delete this Label?' Test above with file resource.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull Master Branch:
      wip-mdl-39116
    • Rank:
      49707

      Description

      Found when testing MDLQA-5535:

      Are you sure that you want to delete this [[pluginname,label]]?

      Steps to reproduce:

      Login as teacher, go to the course page then turn editing on.
      Create a label by dragging an image onto the course page
      Attempt to delete a label.

      Expected result:
      Check that the popup asks to confirm deletion 'Are you sure you want to delete this Label?'

      Actual result:
      The popup says: Are you sure that you want to delete this [[pluginname,label]]?

        Issue Links

          Activity

          Rossiani Wijaya added a comment -

          Thanks Stephen for reporting the issue.

          I confirm this error occurs in qa.moodle.net however testing this with the latest 2.5 integration, it looks fine.

          I will re-test this again on qa.moodle.net when it gets updated.

          Ankit Agarwal added a comment -

          Hi guys,
          The patch looks good. I was concerned about the $modname which would be null when $component is moodle/core and cause a error when calling the js. But since we are doing get_plugin_list_with_function() only for 'mod', it should never happen.
          +1 from me for integration.
          Thanks

          Rajesh Taneja added a comment -

          Thanks Ankit,

          FYI: I discussed with Damyon, about this issue and we thought of adding logic to ajax to update M.str, but when I looked at dnd callback for modules, it seems it will be better to get these strings at page load as they are not much and we do load quite a few strings.
          Also, as we don't have any set_string JS method and adding something like this at code freeze is probably not a nice idea.

          Dan Poltawski added a comment -

          Integrated to master - thanks Raj

          Dan Poltawski added a comment -

          Passing this - to be tested in mdlqa.

          Dan Poltawski added a comment -

          Blooming Marvelous! It's time for a knees up - your changes are upstream!

          Thanks for making Moodle better!

          Toodle pip


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: