Moodle
  1. Moodle
  2. MDL-39164

GIFT, Blackboard and Examview import of essay questions broken

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Questions
    • Labels:
    • Testing Instructions:
      1. GIFT format test
        • Import the file question/format/gift/tests/fixtures/questions.gift.txt choosing "Gift format" for "File format".
        • This should import 9 questions without any error, warning or notice. the question named "Q8" should be a valid essay question with an empty response template.
      2. Examview format test
        • Import the file question/format/examview/tests/fixtures/examview_sample.xml choosing "Examview" for "File format"
        • This should import 6 questions without any error, warning or notice. the question named "How are you?" should be a valid essay question with an empty response template.
      3. Blackboard format test

        Warning: both test for the Blackboard format needs that MDL-39172 is integrated first. If it isn't, import will stop with an error message and no question will be imported

        • Import the file question/format/blackboard_six/tests/fixtures/sample_blackboard_pool.dat choosing "Blackboard" for "File format"
        • This should import 6 questions without any error, warning or notice. the question named "How are you?" should be a valid essay question with an empty response template.
        • Import the file question/format/blackboard_six/tests/fixtures/sample_blackboard_qti.dat choosing "Blackboard" for "File format"
        • This should import 6 questions without any error, warning or notice. the question named "How are you?" should be a valid essay question with an empty response template.
      Show
      GIFT format test Import the file question/format/gift/tests/fixtures/questions.gift.txt choosing "Gift format" for "File format". This should import 9 questions without any error, warning or notice. the question named "Q8" should be a valid essay question with an empty response template. Examview format test Import the file question/format/examview/tests/fixtures/examview_sample.xml choosing "Examview" for "File format" This should import 6 questions without any error, warning or notice. the question named "How are you?" should be a valid essay question with an empty response template. Blackboard format test Warning: both test for the Blackboard format needs that MDL-39172 is integrated first. If it isn't, import will stop with an error message and no question will be imported Import the file question/format/blackboard_six/tests/fixtures/sample_blackboard_pool.dat choosing "Blackboard" for "File format" This should import 6 questions without any error, warning or notice. the question named "How are you?" should be a valid essay question with an empty response template. Import the file question/format/blackboard_six/tests/fixtures/sample_blackboard_qti.dat choosing "Blackboard" for "File format" This should import 6 questions without any error, warning or notice. the question named "How are you?" should be a valid essay question with an empty response template.
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull Master Branch:
    • Rank:
      49763

      Description

      this is a regression from MDL-10516. Some question import formats were not fixed to create the new responsetemplate field when importing essay questions.
      3 differents formats are affected: GIFT, Blackboard and Examview.
      An empty responsetemplate need to be produced when importing an essay question in these fomrats

        Issue Links

          Activity

          Tim Hunt added a comment -

          Jean-Michel, I think this will be easy to fix, so I suggest leaving it for a GSoC applicant.

          Jean-Michel Vedrine added a comment -

          Hello Tim,
          Yes Ithink this is a good idea. Sorry I forgot this when introducing responsetemplate. But this is strange because I was quite sure I tested all imports exports. I will test again just in case something else is broken.

          Jean-Michel Vedrine added a comment -

          Hello Tim,
          I am really sorry but there are other question import formats broken. I don't know what did because I "seem" to remember I worked on this, but the situation is:

          • xml is not broken and import of questions without responsetemplate don't produce any error
          • fortunately aiken, learnwise, missing word, multianswer and xhtml don't know anything about essay questions so they are not broken !
          • blackboard_six, gift and examview are broken and show similar errors messages. Fix is really easy and I think it will interesting to see what some of our GSOC candidates can do to fix it.

          Should I create different issues for each format to give several chances to fix a bug to several candidates ? or is an unique issue better, in that case I will just edit the present issue ?
          Additionally testing this, I discovered a regression from MDL-38388 in blackboard_six: import of .zip files is OK but import of .dat files is broken. I will create a new issue for that. It's only a one line fix.

          Michael de Raadt added a comment -

          Under normal circumstances it would be good to leave this as an easy issue for a student to fix, however, we need to bring this to a resolution so we can pass MDLQA-5340.

          Jean-Michel Vedrine added a comment -

          Thanks Michael,
          Tim, can I assign this to me and fix the 3 imports formats that are broken (gift, blackboard_six, examview)? Each fix is only 2 lines.

          Tim Hunt added a comment -

          Yes, please go ahead.

          Jean-Michel Vedrine added a comment -

          I think that this needs MDL-39172 for the Blackboard import to work but it doesn't have to be based on MDL-39172 because there is no common file changed: MDL-39172 only change question/format/blackboard_six/format.php and this file is not changed by the present issue so there is absolutely no risk of conflict.

          Tim Hunt added a comment -

          How close is MDL-39172 to being fixed?

          If the changes are independent, I think we should submit this for integration sooner rather than later.

          Tim Hunt added a comment -

          +1 for those code changes.

          Should the commit comment mention the other formats that you changed?

          I think you are good to back-port.

          Jean-Michel Vedrine added a comment -

          Hello Tim
          Can you peer review this ?
          This is a short term fix to fix the import formats and to permit MDLQA test to pass.
          For the Blackboard format I seem to remember I once saw a sample file were there was some data that could be imported as responsetemplate for essay questions. So later I will try to improve this format and add import of responsetemplate.
          But it seems better to me not to mix the bugfix and the improvement.
          Additionally I need some time to search all my sample files to find the relevant one !

          Jean-Michel Vedrine added a comment -

          Tim,
          answers to your questions
          for MDL-39172 I only need to fetch the weekly releases rebase, push, cherry pick push so it should not be too long
          it is quite possible to submit this independently from MDL-39172, but in that case we nned to note only gift and examview should be tested and that blackboard will be tested as part of MDL-39172
          if MDL-39172 needs to be backported there is no need to backport this one because responsetemplate is only available in 2.5
          I will change the commit comment, well spotted

          Jean-Michel Vedrine added a comment -

          Commit reworded I will now work on MDL-39172

          Tim Hunt added a comment -

          Doh! Sorry. Of course this is needed for 2.5 only.

          Jean-Michel Vedrine added a comment -

          MDL-39172 is ready now.

          Sam Hemelryk added a comment -

          Thanks Jean-Michel + Tim. This has been integrated now.

          Jean-Michel Vedrine added a comment -

          Thanks Sam,
          Note that Blackboard import can only be tested if MDL-39172 is integrated too.

          Rajesh Taneja added a comment -

          Thanks for fixing this Jean-Michel,

          I was able to import Gift, Examview and Blackboard file formats in Question bank without any notice/warning.

          Essay type questions were imported correctly.

          Eloy Lafuente (stronk7) added a comment -

          I feel myself really alone tonight! So was time to push your fixes upstream!

          "Lest we forget. We will remember them."

          Thanks and ciao!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: