Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-39194

course listing in formal_white is not nice to see with borders and info icon not vertically centered

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5.1
    • Component/s: Themes
    • Labels:
    • Testing Instructions:

      Change the frontpage settings so the Combo List is visible on the frontpage.
      Make sure there are a few courses and categories.
      Go to the front page and look at the list of courses.
      The application of this patch should change your page from the one described in problem.png to the one described in bonfire-screenshot-20130527-155220-700.png

      Show
      Change the frontpage settings so the Combo List is visible on the frontpage. Make sure there are a few courses and categories. Go to the front page and look at the list of courses. The application of this patch should change your page from the one described in problem.png to the one described in bonfire-screenshot-20130527-155220-700.png
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-39194_master

      Description

      Attached are two screen shots explainig the issue and the expected solution.

        Gliffy Diagrams

          Attachments

            Activity

            salvetore Michael de Raadt added a comment -

            Nice.

            poltawski Dan Poltawski added a comment -

            Hi Danielle,

            I'm reopening this one because I think that Marina has fixed this one this week in MDL-38594

            daniss Daniele Cordella added a comment -

            Yes Dan, I waited a week in order to be sure all changes were onboard of my local computer.
            I can confirm that what I changed is something coming AFTER Marina's intervention.
            Because of this, I start and close the peer review in order to straightly proceed to "Waiting for integration review" as it was before.
            Thanks for your prudence!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Sorry is this master only? (the affects version field indicates the opposite).

            daniss Daniele Cordella added a comment -

            Yes Eloy,
            this is for master only because it is a step forward after the intervention of Marina that was limited to master only.
            I feel the "affects version" field was filled by me in error.
            Sorry!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            damyon Damyon Wiese added a comment -

            Hi Danielle,

            This is conflicting with both master and 25 (and it's not obvious to resolve). Can you please resolve the conflicts and resubmit for integration?

            Thanks!

            cibot CiBoT added a comment -

            Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.

            daniss Daniele Cordella added a comment -

            ok Damyon, I resolved conflicts against master.
            I already changed the status to "Waiting for peer review".
            I try now to resubmit for integration.

            lazydaisy Mary Evans added a comment -

            I prefer the way it looks normally without your changes Daniele. In the 'problem' image, the eye travels along the line (left to right) and finds the icon is resting 'on the line'. In your 'expected' result the image drops below the line.

            daniss Daniele Cordella added a comment -

            You are right, the 'i' in the circle is not perfectly vertically centered but this is a detail strongly depending from browser and computer architecture.
            On the opposite side:
            -> the first row for courses is now gray [and not grey, as I learned from you. Thanks Mary! ;-)] and not white. This helps the color alternation.
            -> upper and lower border line are no longer present (the borders are only weights for the colored rows because the colour already delimits each row)
            -> ugly useless border, even around white rows, is finally missing
            -> the deleted border had an ugly non homogeneous width, too
            Do you agree?
            Let me know your opinion, please.

            lazydaisy Mary Evans added a comment -

            Grey or Gray why not just grigio because it sounds nicer.

            Joking apart I have never liked navigational lists with colours and borders, I prefer to see a written list flat on the page. But the way you have it looks good.

            damyon Damyon Wiese added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            damyon Damyon Wiese added a comment - - edited

            Hi Daniele,

            I have integrated this to master and 25 branches. I updated the screenshot for the testing instructions because it has changed since you first started working on it.

            For me, I think the gray used as the background for the odd rows is too similar to the header and they run into each other (But it does look better than it did before).

            rwijaya Rossiani Wijaya added a comment -

            I noticed the expandable functionality for the subcategory is not working properly and has been reported in MDL-23465.

            Apart from the above statement, this is working as expected.

            Tested for 2.5 and master

            Test passed.

            damyon Damyon Wiese added a comment -

            Thanks for your hard work. This issue has now been sent upstream and will soon be downloaded by millions of Moodlers!

            Regards, Damyon


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  8/Jul/13