Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-39279

POLICY: require version.php strictly 100% for all plugins 2.5 onwards

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: None
    • Component/s: Policy
    • Labels:
      None
    • Affected Branches:
      MOODLE_25_STABLE

      Description

      see MDLSITE-1937 and MDLSITE-2178

      Some plugins without version.php are causing inconsistencies. Adding a version.php requirement only makes it easier and more consistent to deal with versions of the plugin, dependencies and requirements.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dougiamas Martin Dougiamas
              Reporter:
              nebgor Aparup Banerjee
              Participants:
              Component watchers:
              Adrian Greeve, Andrew Lyons, Eloy Lafuente (stronk7), Juan Leyva, Jun Pataleta, Sander Bangma
              Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: