Moodle
  1. Moodle
  2. MDL-39434

Bump all versions, requires and dependencies near 2.5 release in master

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: General, Installation
    • Labels:
    • Testing Instructions:

      1) TEST: Visually verify that all the changes in the patch point to the correct "2013050100" version and nothing else is changed. Note main version.php file is >= "2013050100".

      2) Upgrade from any previous 2.2.x, 2.3.x, 2.4.x or 2.5dev version.

      3) TEST: In the plugins screen ALL the plugins are showing "to upgrade".

      4) TEST: All the target versions and all the dependencies show the "2013050100" version along the whole page.

      5) TEST: Run upgrade. Ends without error.

      6) TEST: To integrators, verify the "Check version.php files (master)" job in the integration server ends without error, that everything points to "2013050100" version and that the report does not include any "ERROR" looking to the generated "versions_check_set.txt" file in the workspace. Note some "WARN" can exist. But that's not relevant for this issue.

      Show
      1) TEST: Visually verify that all the changes in the patch point to the correct "2013050100" version and nothing else is changed. Note main version.php file is >= "2013050100". 2) Upgrade from any previous 2.2.x, 2.3.x, 2.4.x or 2.5dev version. 3) TEST: In the plugins screen ALL the plugins are showing "to upgrade". 4) TEST: All the target versions and all the dependencies show the "2013050100" version along the whole page. 5) TEST: Run upgrade. Ends without error. 6) TEST: To integrators, verify the "Check version.php files (master)" job in the integration server ends without error, that everything points to "2013050100" version and that the report does not include any "ERROR" looking to the generated "versions_check_set.txt" file in the workspace. Note some "WARN" can exist. But that's not relevant for this issue.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Rank:
      50088

      Description

      This task corresponds to point #3 of:

      http://docs.moodle.org/dev/Major_release_process#One_week_before

      And it's achieved in a semi-automated way with the "versions_check_set.sh" script available @ https://github.com/moodlehq/moodle-local_ci/blob/master/versions_check_set/versions_check_set.sh

      1) In a git, working, master site with the ci local plugin installed.

      2) Define and export all the env variables required by the script.

      • $WORKSPACE: Path to the directory where test reults will be sent (/tmp)
      • $phpcmd: Path to the PHP CLI executable (/usr/bin/php)
      • $gitdir: Directory containing git repo (the dirroot of the git, working site)
      • $setversion: 10digits (YYYYMMDD00) to set all versions to. Empty = not set

      3) Run it. With errors, they will be reported and fixing will be necessary. (look for ERROR in the $WORKSPACE/versions_check_set.txt file and/or check exit status of the script)

      4) Without errors, all the versions, requires and dependencies will be bumped.

      5) Commit

      6) Note that the main version file is NOT updated at all. One extra commit bumping it may be necessary.

      7) Run the checker again to verify that there are no errors and no more changes are performed.

      Note the checker is also run periodically by the ci server and also as part of the "remote_branch_checker", so normally all the version.php files should be under control.

      (This issue will be cloned for each major release).

      Ciao

        Issue Links

          Activity

          Eloy Lafuente (stronk7) added a comment -

          Sending to integration, 2 commits on top of current integration.

          Dan Poltawski added a comment -

          Integrated to master. Thanks Eloy

          Dan Poltawski added a comment -

          Will take testing on this one then..

          Dan Poltawski added a comment -

          Passed the test, I updated the testing instructions to what I think the intention was Eloy

          Dan Poltawski added a comment -

          Thanks! You're changes are now spread to the world through this git and our source control repositories.

          No time to rest though, we've got days to make 2.5 the best yet!

          ciao

          Michael de Raadt added a comment -

          Hi, Dan.

          I think it would be more productive if you didn't take other people's work. There is plenty of other work to do.

          After undertaking this test I can confirm that the version numbers changed by the patch are consistent and the version bump works. I can't say if there are any missing changes that were not made.

          Martin Dougiamas added a comment -

          I think Dan was fine to grab this since the bug had not yet been flagged as "Testing in progress" and he was trying to mop up the backlog of tests.

          In any case a second test never hurts. Thanks all, we are getting close.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: