Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Feedback
    • Labels:
    • Testing Instructions:
      Hide

      Throughout the test you should not see any setType error

      1. Create AND edit a new feedback
      2. Confirm that the form works correcty (try several combination)
      3. Add AND edit each type of questions in the feedback
      4. Confirm that everything works correctly
      Show
      Throughout the test you should not see any setType error Create AND edit a new feedback Confirm that the form works correcty (try several combination) Add AND edit each type of questions in the feedback Confirm that everything works correctly
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-39435-master-int

      Description

      This appeared when editing the settings of a feedback with submitted answers:

      Did you remember to call setType() for 'multiple_submit_static'? Defaulting to PARAM_RAW cleaning.
       
          line 1289 of /lib/formslib.php: call to debugging()
          line 281 of /lib/formslib.php: call to moodleform->detectMissingSetType()
          line 202 of /lib/formslib.php: call to moodleform->_process_submission()
          line 71 of /course/moodleform_mod.php: call to moodleform->moodleform()
          line 248 of /course/modedit.php: call to moodleform_mod->moodleform_mod()
       
      Did you remember to call setType() for 'multiple_submit'? Defaulting to PARAM_RAW cleaning.
       
          line 1289 of /lib/formslib.php: call to debugging()
          line 281 of /lib/formslib.php: call to moodleform->detectMissingSetType()
          line 202 of /lib/formslib.php: call to moodleform->_process_submission()
          line 71 of /course/moodleform_mod.php: call to moodleform->moodleform()
          line 248 of /course/modedit.php: call to moodleform_mod->moodleform_mod()
      

      This appeared for a short answer question, surely other forms should be checked!

      Did you remember to call setType() for 'dependvalue'? Defaulting to PARAM_RAW cleaning.
       
          line 1289 of /lib/formslib.php: call to debugging()
          line 281 of /lib/formslib.php: call to moodleform->detectMissingSetType()
          line 202 of /lib/formslib.php: call to moodleform->_process_submission()
          line 77 of /mod/feedback/item/textfield/lib.php: call to moodleform->moodleform()
          line 102 of /mod/feedback/edit_item.php: call to feedback_item_textfield->build_editform()
      

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                14/May/13