Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Lesson
    • Labels:
      None

      Description

      The 'add a question page' section name should be renamed to avoid conflict with the 'add a question page' button in Behat tests.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Just to confirm that this seems to prevent the alert=> exception problem in behat, so now mod_lesson tests are all run (although there are still 2 failed steps), both in the same scenario:

              • Forbidding lesson accesses until a specified date.

              Although that may be unrelated to this.

              dmonllao David Monllaó added a comment -

              Looks good Rossie, I've ran the scenario and it passed, sending to integration

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Sorry, but I continue getting 2 errors with mod_lesson, grrr:

              01. Exception thrown by (//html/.//input[./@type = 'checkbox'][(((./@id = 'id_available_enabled' or ./@name = 'id_available_enabled') or ./@id = //label[contains(normalize-space(string(.)), 'id_available_enabled')]/@for) or ./@placeholder = 'id_available_enabled')] | .//label[contains(normalize-space(string(.)), 'id_available_enabled')]//.//input[./@type = 'checkbox'])[1]
                  Element is not currently visible and so may not be interacted with
                  Command duration or timeout: 9 milliseconds
                  Build info: version: '2.32.0', revision: '6c40c18', time: '2013-04-09 17:22:56'
                  System info: os.name: 'Mac OS X', os.arch: 'x86_64', os.version: '10.8.3', java.version: '1.6.0_45'
                  Session ID: 81132b9e-6325-f649-bf59-6862669d859b
                  Driver info: org.openqa.selenium.firefox.FirefoxDriver
                  Capabilities [{platform=MAC, acceptSslCerts=true, javascriptEnabled=true, browserName=firefox, rotatable=false, locationContextEnabled=true, version=20.0, cssSelectorsEnabled=true, databaseEnabled=true, handlesAlerts=true, browserConnectionEnabled=true, nativeEvents=false, webStorageEnabled=true, applicationCacheEnabled=true, takesScreenshot=true}]
                  In step `And I click on "id_available_enabled" "checkbox"'.                          # behat_general::i_click_on()
                  From scenario `Forbidding lesson accesses until a specified date'.                   # /Users/stronk7/git_moodle/integration/mod/lesson/tests/behat/date_availability.feature:24
                  Of feature `A teacher can set available from and deadline dates to access a lesson'. # /Users/stronk7/git_moodle/integration/mod/lesson/tests/behat/date_availability.feature
               
              02. Exception thrown by (//html/.//input[./@type = 'checkbox'][(((./@id = 'id_deadline_enabled' or ./@name = 'id_deadline_enabled') or ./@id = //label[contains(normalize-space(string(.)), 'id_deadline_enabled')]/@for) or ./@placeholder = 'id_deadline_enabled')] | .//label[contains(normalize-space(string(.)), 'id_deadline_enabled')]//.//input[./@type = 'checkbox'])[1]
                  Element is not currently visible and so may not be interacted with
                  Command duration or timeout: 6 milliseconds
                  Build info: version: '2.32.0', revision: '6c40c18', time: '2013-04-09 17:22:56'
                  System info: os.name: 'Mac OS X', os.arch: 'x86_64', os.version: '10.8.3', java.version: '1.6.0_45'
                  Session ID: 81132b9e-6325-f649-bf59-6862669d859b
                  Driver info: org.openqa.selenium.firefox.FirefoxDriver
                  Capabilities [{platform=MAC, acceptSslCerts=true, javascriptEnabled=true, browserName=firefox, rotatable=false, locationContextEnabled=true, version=20.0, cssSelectorsEnabled=true, databaseEnabled=true, handlesAlerts=true, browserConnectionEnabled=true, nativeEvents=false, webStorageEnabled=true, applicationCacheEnabled=true, takesScreenshot=true}]
                  In step `And I click on "id_deadline_enabled" "checkbox"'.                           # behat_general::i_click_on()
                  From scenario `Forbidding lesson accesses until a specified date'.                   # /Users/stronk7/git_moodle/integration/mod/lesson/tests/behat/date_availability.feature:50
                  Of feature `A teacher can set available from and deadline dates to access a lesson'. # /Users/stronk7/git_moodle/integration/mod/lesson/tests/behat/date_availability.feature
               
              5 escenarios (3 exitosos, 2 fallidos)
              139 pasos (113 exitosos, 24 omitidos, 2 fallidos)

              (note that before the patch I get the 5 scenarios failing)

              Also, as far as this introduces a small change in the visualization (new header) and it's not verified by behat... this should have some simple human testing instructions covering it.

              I'll keep this open (and NOT integrated), until some feedback lands... ciao

              dmonllao David Monllaó added a comment -

              I've confirmed that this last 2 failures are caused by MDL-39270 changes, adding Fred as a watcher. If you are changing a lesson form, please, run the behat tests before sending to integration, the same is applicable for all issues and not only related with forms, but forms is a critical part and even more with big changes like this.

              Adding a quick fix for this on top of this MDL-39437 patch: git pull git://github.com/dmonllao/moodle.git MDL-39437_master-fix

              rwijaya Rossiani Wijaya added a comment - - edited

              Thanks David for the patch.

              I pushed David's patch on top of mine.

              Running the test locally now. Will post the result soon.

              rwijaya Rossiani Wijaya added a comment -

              Behat test passed successfully.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated, thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Passing, got all mod_lesson passing too and the new string was correctly displayed when adding a question. Thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Did you think this day was not going to arrive ever?

              Your patience has been rewarded, yay, sent upstream, thanks!

              Closing...ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    14/May/13