Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-39442

Warnings when attempting to install an add-on

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Administration
    • Labels:
    • Testing Instructions:

      Testing difficulty: hard (requires moodledata on separate partition)

      1. Set up your Moodle so that $CFG->dataroot is located at other partition than $CFG->dirroot (hint: I used mounted USB flash disk for that).
      2. TEST: Try to install a new add-on via the "Install add-on" admin tool.

      Hint: Luckily, qa.moodle.net seems to already have the required setup. It should be enough to re-try the add-on installation there once this patch lands there.

      Note: It would be nice to have this tested on Windows, too. There, moodledata should be located at different drive than Moodle itself is.

      Show
      Testing difficulty: hard (requires moodledata on separate partition) 1. Set up your Moodle so that $CFG->dataroot is located at other partition than $CFG->dirroot (hint: I used mounted USB flash disk for that). 2. TEST: Try to install a new add-on via the "Install add-on" admin tool. Hint: Luckily, qa.moodle.net seems to already have the required setup. It should be enough to re-try the add-on installation there once this patch lands there. Note: It would be nice to have this tested on Windows, too. There, moodledata should be located at different drive than Moodle itself is.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-39442-copy-addon

      Description

      After seeing the 'Validation passed!' message and clicking the button 'Install add-on', I obtain the following error message:

      Warning: rename() [function.rename]: The first argument to copy() function cannot be a directory in /html/admin/tool/installaddon/deploy.php on line 74

      Warning: rename(/moodledata/temp/tool_installaddon/dbaeff1efdf1605cdc71d619ad74aa5c/contents/checklist,/html/mod/checklist) [function.rename]: Invalid cross-device link in /html/admin/tool/installaddon/deploy.php on line 74

      (Using http://qa.moodle.net)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              mudrd8mz David Mudrák added a comment -

              Well spotted! I am able to reproduce the error when having the moodledata located at mounted USB flash disk. This is caused by https://bugs.php.net/bug.php?id=54097 Going to work on this now.

              mudrd8mz David Mudrák added a comment -

              Submitting for integration.

              poltawski Dan Poltawski added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              tsala Helen Foster added a comment -

              Just noting that now the QA testing site SSL certificate problem (MDLSITE-2237) is fixed, attempting to install an add-on directly now also fails with the same error message.

              poltawski Dan Poltawski added a comment -

              Integrated to master - thanks David

              rajeshtaneja Rajesh Taneja added a comment -

              Thanks for fixing this David,

              Works fine on ubuntu.
              Couldn't test this on windows.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Did you think this day was not going to arrive ever?

              Your patience has been rewarded, yay, sent upstream, thanks!

              Closing...ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    14/May/13