Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-39642

Import fixed English strings (en_fix) into the main English pack

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.6, 2.4.3, 2.5
    • Fix Version/s: 2.3.7, 2.4.4
    • Component/s: Language
    • Labels:

      Description

      As a part of regular release process, en_fix pack from AMOS should be merged into the core English language

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              mudrd8mz David Mudrák added a comment -

              Submitting for integration.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              23 and 24 ok, I got this conflict on master:

              <<<<<<< HEAD
              $string['adminonly'] = 'This page is restricted to Site Administrators only';
              =======
              $string['adminaward'] = 'As a site administrator, you can select a role to award this badge.';
              $string['adminonly'] = 'This page is restricted to site administrators only.';
              >>>>>>> FETCH_HEAD

              Just guessing if you want to change to camelcase "site administrator" in the new one.

              Ciao

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Oki, it's a deleted string @ integration today, so fixing conflict and going ahead...

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated (23, 24 & master), thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Just In Time® for stable releases, thanks!

              Closing as fixed, ciao

              tsala Helen Foster added a comment -

              Just noting that the problem was caused by my misunderstanding MDL-33217.

              rajeshtaneja Rajesh Taneja added a comment -

              Hello Helen,

              Was working on MDL-37558 and realise definition for courselistshortnames_desc has been changed from

              When showing lists of courses, or when referring to courses on administration screens, show the course short name as well as the full name. In fact, when you turn this setting on, the display uses the 'courseextendednamedisplay' language string, so you can change what is displayed using Language customisation. 

              to

              'If enabled, course short names will be displayed in addition to full names in course lists. If required, extended course names may be customised by editing the \'courseextendednamedisplay\' language string using the language customisation feature.

              Previously this configuration was only for administration screens and not with new definition it is not constrained to admin screens. Is this acceptable?

              tsala Helen Foster added a comment -

              Just noting for anyone else reading this issue, that the lang string courselistshortnames_desc was indeed changed (as part of MDL-34704 and MDL-36259) to refer to course lists, rather than admin screens, so if the setting applies to course lists elsewhere e.g. in the courses block, then all well and good.


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    13/May/13