Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-39679

Description of how to manually install language packs could at least provide a link

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5
    • Component/s: Language
    • Labels:
      None
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE

      Description

      When trying to install a language pack immediately after 2.5 was released I got this. Note that the error is correct. 2.6 didnt exist yet.

      cURL request for "http://download.moodle.org/langpack/2.6/languages.md5" failed, HTTP response code: HTTP/1.1 404 Not Found
       
          line 1362 of /lib/filelib.php: call to debugging()
          line 683 of /lib/componentlib.class.php: call to download_file_content()
          line 244 of /admin/tool/langimport/index.php: call to lang_installer->get_remote_list_of_languages()
       
      Because Moodle can not connect to download.moodle.org, we are unable to do language pack installation automatically. Please download the appropriate zip file(s) from http://download.moodle.org, copy them to your /home/andrew/Desktop/tempdata/moodledata/dev/master/lang/ directory and unzip them manually.
      

      HOWEVER, http://download.moodle.org could at least be a proper link instead of making me copy and paste the URL.

        Attachments

          Activity

            People

            Assignee:
            tsala Helen Foster
            Reporter:
            andyjdavis Andrew Davis
            Participants:
            Component watchers:
            David Mudrák (@mudrd8mz), Helen Foster, Víctor Déniz Falcón
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              14/May/13