Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-39704

Properly align and widen the chat bubbles in mod/chat, when in RTL mode

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4.5, 2.5, 2.6
    • Fix Version/s: 2.4.6, 2.5.2
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      1. Switch to RTL mode (set language to Hebrew or Arabic)
      2. Open two different browsers and login as two different users
      3. Navigate into a Chat activity (with both users)
      4. Click to open the regular chat window
      5. Switch chat theme to "bubble"
      6. Make sure all the issues in the description are resolved (see first screen capture)
      Show
      Switch to RTL mode (set language to Hebrew or Arabic) Open two different browsers and login as two different users Navigate into a Chat activity (with both users) Click to open the regular chat window Switch chat theme to "bubble" Make sure all the issues in the description are resolved (see first screen capture)
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE, MOODLE_26_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-39704_master

      Description

      1. user name is hidden
      2. user's icon is displayed to the left of the bubble message
      3. bubble's pointer points to the wrong direction
      4. bubble's overlap (chat entry should be wider)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              andyjdavis Andrew Davis added a comment -

              Heres what it looks like using Standard and an LTR language. https://tracker.moodle.org/secure/attachment/32778/LTRStandardBubblechat.png

              Here's what it looks using Clean and a RTL language. https://tracker.moodle.org/secure/attachment/32779/RTLCleanChatBubble.png

              bawjaws David Scotson added a comment -

              Can I assume that since the screenshots only show Standard+LTR and Clean+RTL that it looks and works fine in Standard+RTL and Clean+LTR?

              andyjdavis Andrew Davis added a comment -

              In short, no.

              lazydaisy Mary Evans added a comment - - edited

              Just added Nadav who is our resident RTL Expert!

              @Nadav, when you have a moment to spare can you suggest how this should be corrected?
              Thanks
              Mary

              nadavkav Nadav Kavalerchik added a comment - - edited

              I have just tested (theme/clean) it on my local update master branch and it look OK.
              Without the green border bubble chat around the text. Is that a new feature?
              ( Attaching screen capture of what I see )

              abarbary Adam Barbary added a comment -

              One extra thing, it doesn't wrap properly either. Compact handles wrapping fine, but Bubble not so well.

              nadavkav Nadav Kavalerchik added a comment -

              Adam & Andrew, have you made any changes to the core theme/clean ?
              (Since, I can not reproduce this issue on my Moodle 2.6dev master )

              nadavkav Nadav Kavalerchik added a comment -

              Also tested with qa.moodle.net (theme/clean & lang = Hebrew)
              http://qa.moodle.net/course/view.php?id=2&lang=he&theme=clean
              And could not reproduce.

              andyjdavis Andrew Davis added a comment -

              Hi Nadav. It appears that you're using the wrong chat theme. In the chat window at the bottom there is a text box, a send button and link that says "themes" (when in English). The default theme is "compact" and seems to function correctly. That's the theme in your screenshot. If you switch to "bubble" you should see the problem.

              nadavkav Nadav Kavalerchik added a comment -

              Andrew Davis, You are right. oups. now I see it.
              I am attaching a screen capture of how it should look when it is fixed (and fixing it too)

              nadavkav Nadav Kavalerchik added a comment -

              FYI, I have removed the theme/clean (theme/bootstrapbase) epic link since it is related to the mod/chat internal CSS bubble theme.

              andyjdavis Andrew Davis added a comment -

              Hi. Just wanted to point out that there is another issue in the works in the same area of Moodle. MDL-39770

              lazydaisy Mary Evans added a comment -

              LOOKS OK SO PUSHING FOR INTEGRATION REVIEW

              stronk7 Eloy Lafuente (stronk7) added a comment -

              We need clarification about this... only affects master, also 25_STABLE.. and 24_STABLE ? Give some clue! TIA

              nadavkav Nadav Kavalerchik added a comment -

              I confirm, It should be applied to master, also 25_STABLE and 24_STABLE.
              I could be cherry picked from master. (same CSS code in 25_STABLE and 24_STABLE)

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Thanks Nadav!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated (24, 25 & master), thanks!

              fred Frédéric Massart added a comment -

              Test passes, however, as I mentioned on MDL-39770, long bubbles are not readable at all.

              damyon Damyon Wiese added a comment -

              Thanks again for another week of fixes, improvements and testing. These changes have been released to the world.

              Cheers, Damyon


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    9/Sep/13