Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5.1
    • Component/s: Tags
    • Labels:

      Description

      When editing a tag the following debugging message appears:
      Did you remember to call setType() for 'rawname'? Defaulting to PARAM_RAW cleaning.
      line 1303 of /lib/formslib.php: call to debugging()
      line 281 of /lib/formslib.php: call to moodleform->detectMissingSetType()
      line 202 of /lib/formslib.php: call to moodleform->_process_submission()
      line 83 of /tag/edit.php: call to moodleform->moodleform()

      Steps to reproduce:
      *Add the tags block to a course and add a tag
      *Click on the tag to get to /tag/index.php?tag=yourtag
      *Click to edit the tag. You can edit it but the above message appears.

      Tested on QA Moodle and local host Moodle Moodle 2.6dev (Build: 20130530)

        Gliffy Diagrams

          Attachments

            Activity

            tsala Helen Foster added a comment -

            Mary, thanks for your report.

            Just wondering whether our setType()-removing-specialist Dan Poltawski wishes to quickly fix this issue?

            poltawski Dan Poltawski added a comment -

            yup

            poltawski Dan Poltawski added a comment -

            The PARAM_ type is kinda ironic (since it seems to be valid to have tags with spaces in it NOTAG is the best!)

            Sending for integration.

            poltawski Dan Poltawski added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            samhemelryk Sam Hemelryk added a comment -

            Thanks Dan - this has been integrated now.

            rajeshtaneja Rajesh Taneja added a comment -

            Thanks for fixing this Dan,

            No setType warning occurred.

            marina Marina Glancy added a comment -

            Thanks for your awesome work! This has now become a part of Moodle.

            Closing as fixed!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  8/Jul/13