Moodle
  1. Moodle
  2. MDL-40255

No file upload with boxxie and formfactor

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.4, 2.4, 2.5, 2.6
    • Fix Version/s: 2.3.8, 2.4.5, 2.5.1
    • Component/s: Themes
    • Labels:
    • Rank:
      51022

      Description

      1) Choose theme formfactor or theme boxxie
      2) Turn editing on
      3) + Add an activity or resource
      4) choose File
      5) Add
      6) Instead of the blue arrow you only get the small loading image

        Issue Links

          Activity

          Dietmar Wagner added a comment -

          screenshot

          Mary Evans added a comment -

          Thanks for reporting this Dietmar. Did you test this in other browsers?

          Dietmar Wagner added a comment -

          Hi Mary.
          I tested this in FF, IE, SAF, CHR - always with the same result.
          In Moodle 2.6 we do not have problems at this point!
          I have no idea!

          Mary Evans added a comment -

          @Dietmar, I found what the problem is by a process of elimination. Both those themes are similar in that you cannot dock blocks in them, so are both missing class="block-region" from <div id="region-pre"> & <div id="region-post">.

          Adding the block-region class makes it work as it should, which is odd, but understandable when I was telling Andrew Nicols about this earlier today in DEV chat. Apparently these 'regions' are causing problems generally in themes, so looks like we may need to add something like $THEME->regions = array(); similar to how layouts are listed in config.php.

          Anyway I shall be fixing this BUG later today.

          Cheers
          Mary

          Mary Evans added a comment -

          @Dietmar, I found what the problem is by a process of elimination. Both those themes are similar in that you cannot dock blocks in them, so are both missing class="block-region" from <div id="region-pre"> & <div id="region-post">.

          Adding the block-region class makes it work as it should, which is odd, but understandable when I was telling Andrew Nicols about this earlier today in DEV chat. Apparently these 'regions' are causing problems generally in themes, so looks like we may need to add something like $THEME->regions = array(); similar to how layouts are listed in config.php.

          Anyway I shall be fixing this BUG later today.

          Cheers
          Mary

          Dietmar Wagner added a comment - - edited

          Hmmm.

          Mary,

          I changed

          <div id="region-pre/post">

          to

          <div id="region-pre/post" class="block-region">

          as suggested in formfactor and tested with FF+Moodle25. But: the file upload still doesn't work.

          And: After eleminating the class block-region from brick the file upload is still working?

          More confusing: File upload works with Moolde26 although the class block-region is missing too!?

          Do we need more tests?

          D.

          Mary Evans added a comment -

          OK...let me try again.

          Mary Evans added a comment -

          I was testing in Moodle 2.6 and nothing worked until I added the block-region class.

          Dietmar Wagner added a comment -

          Mary, I made some new tests - still with confusing results .

          I took a brandnew 2.6dev (Build: 20130621) via git. After adding the class block-region to the ids region-pre and region-post file upload with FF and formfactor works fine ! So, you are right, your idea really works for 2.6.

          Unfortunately the same procedure in a brandnew 2.5+ (Build: 20130621) failed with formfactor and boxxie on my system.

          On the other hand: File upload with 2.5 and brick works fine! After eliminating class block-region: failure! That's a good result too!

          Somehow crazy, isn't it?
          -------
          One question: How can I highlight code-snippets here?

          Dietmar Wagner added a comment -

          Sorry Mary,
          after correcting some typos (not my day!!) e v e r y t h i n g works fine when adding class block-region to the regions in 2.5.

          Fixed!
          Sorry again. I better finish my work for today.

          Mary Evans added a comment - - edited

          I thoght that must have been the problem...but did not like to say as I was not sure what is casuing the problem. Now you have got it working then all is OK and I can fix the 'BUG'.

          As for highlighting code here. If you look at the bottom of this comments text editor box you should see a blue icon that looks like a computer screen (preview) and next to it is a yellow ? (help) icon. If you click that it gives you a list of tags you can use to display text code whatever.

          But to add code here I use the code tag like this:

          {code}
          <div id="region-pre" class="block-region">
              ...
              ...
              ...
          </div>
          {code}
          
          Dietmar Wagner added a comment -

          Thanks Mary - for these hints and your patience .
          I will report now your solution in the german forum.
          Dietmar

          Mary Evans added a comment -

          das ist gut ja? danke

          Eloy Lafuente (stronk7) added a comment -

          Integrated (23, 24, 25 & master), thanks!

          PS: Please, don't mix bug fixes and coding style/whitespace fixes in the same commit, it makes things really harder to review. Use a separate commit and all we will love you (more!). TIA!

          Mary Evans added a comment -

          I am very sorry about the white-space clean-up but this was not my intention. I saw them first after I pushed to origin. So I deleted the original branches and started over again only to get the same result, so it must be my Text Editor picking up old white space and stuff left behind at some point over the years. Patrick Malley used a MAC so may be that. I recall John Stabinger getting told off by you or Sam because of all the tabs and white space he had generated in his code.

          Sam Hemelryk added a comment -

          Thanks guys, tested and works perfectly.

          Eloy Lafuente (stronk7) added a comment -

          Thanks for giving me joys and smiles
          Thanks for sharing my trouble's pile

          Thanks for wipeing the tears of my eye
          Thanks for showing me the glad view of sky

          Thanks for lending me your shoulders to lean
          Thanks for giving my words a proper mean

          Thanks for telling me the value of life
          Thanks for showing me the rules to survive

          Thanks for lending me the sympathetic ears
          Thanks for showing how much you care

          From all this what I mean in the end
          Is thanks for being my special friend.

          – Seema Chowdhury

          Sent upstream so... closing, thanks!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: