Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-40282

Collapsible editor loses border in IE8-9

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.5.1
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None
    • Testing Instructions:

      Using Internet explorer 8 and/or 9.

      Open a question editing form and find a question with a collapsible editor. true/false > general > feedback fields for example.

      The attached screenshots show that the border of the collapsible editor should fit correctly the textarea. Instead it ends shortly to the right of the 'show editing tools' button.

      Show
      Using Internet explorer 8 and/or 9. Open a question editing form and find a question with a collapsible editor. true/false > general > feedback fields for example. The attached screenshots show that the border of the collapsible editor should fit correctly the textarea. Instead it ends shortly to the right of the 'show editing tools' button.
    • Affected Branches:
      MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_25_STABLE
    • Pull from Repository:
      git@github.com:colchambers/moodle.git
    • Pull Master Branch:

      Description

      The tinymce text area border disappears on the right of the text area on IE 8 & 9. Attached an image to explain. At the top the feedback editor is highlight to show how the editor text area should appear.

      Below the correct response editor is highlighted showing the problem.

        Gliffy Diagrams

          Attachments

            Activity

            colchambers Colin Chambers added a comment -

            The issue fixed

            colchambers Colin Chambers added a comment -

            A very simple fix. Just cleared the editor table width. Copying the existing line clearing the height for a similar reason.

            Only affects IE 8&9. Not everyone with IE seems to have the problem.

            timhunt Tim Hunt added a comment -

            +1 from me.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            colchambers Colin Chambers added a comment -

            Thanks Eloy. Done.

            poltawski Dan Poltawski added a comment -

            Integrated to master and 25, thanks Colin.

            (BTW I am sure I saw a duplicate of this somewhere, but searching I can't find it)

            rwijaya Rossiani Wijaya added a comment -

            This is working as expected.

            Tested for 2.5 and master for IE8 and 9.

            Test passed.

            damyon Damyon Wiese added a comment -

            This issue is fixed! Hurray! Hurray!
            Your issue is fixed, what a wonderful day!

            Cheers, Damyon


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  8/Jul/13